Support » Plugin: Contact Form by BestWebSoft » Contact Form Display Different from Settings

  • Resolved hirschid


    I have changed the settings for Contact Form to display the field Telephone, have marked Name, Email and Message as required, and have not checked ‘Display send me a copy block.’

    However, when I check the contact page on my website it does not display the field Telephone, does not mark the required fields with an asterisk and it is displaying the ‘send me a copy’ block.

    It appears to be displaying the default values without regard to the settings I changed.

    Also, after sending an email I simply get the message “Your email was sent successfully” not the text I entered in my settings.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m having exactly the same issues. I’m wondering whether another plug-in is causing a conflict? I’m using woocommerce, with the resort theme, and the jetpack is installed (although I’ve disabled the jetpack contact forms, but to no effect, AFAICT.)

    I installed this plugin on another server and on a site which does not use WooThemes and it worked. Maybe woo uses the same shortcode for its contact form and so the form you see is actually woo’s contact form? I’ll look into this more and post results.

    Sounds very plausible. I wonder if there is a simple way to change the shortcode for this plugin to, say, bws_contact_form. (It would be better branding, anyway.)

    Thanks for helping to track this one down.

    Actually, I just experimented with hacking the bws contact form to change the shortcode to [bws_contact_form], and yes, the conflict is now resolved — it’s working properly.

    I had to change the captcha.php as well to work with the hacked contact form plugin, but (hacked) captcha works with (hacked) contact-forms-plugin.

    What I did was pretty quick and dirty (mostly global search and replace). Perhaps the author might consider doing a proper fix to resolve the conflict?

    I’ve just cleaned my hacked version up a bit and now it plays nicely with a (non-hacked) version of BWS Captcha. I had to revert the filename and directory names as contact_form.php and contact-form-plugin respectively. (I had changed these to be bws_contact_form.php and bws-contact-form-plugin, but BWS Captcha couldn’t find these without being modified itself.)

    All working quite nicely! Just tested the attachment feature, no problems.

    The only other custom modification I did was to prepend an identifying text string “[] ” before the contact message subject string, so I can easily see it came from the contact form and site when it hits my inbox. This might also be a useful future option to be rolled into an official release (the prepend string is just hard-coded in the php file the way I’ve done it… have to redo it with every upgrade.)

    Anyway, it would be good to get the shortcode conflict with woocommerce resolved. [woo_contact_form] and [bws_contact_form] would be much better ideas all around.

    Plugin Author bestwebsoft


    Hello plugger2,

    Please provide a screenshot of setting page in admin area. But it seems that you chose another plugin.

    Kind regards,
    Support Team

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Contact Form Display Different from Settings’ is closed to new replies.