Support » Plugin: Contact Form 7 » Contact Form 7 (Version 4.8) – Sending does not work

  • Resolved Lawless-Diablo

    (@lawless-diablo)


    Hello

    I have just found that the CF7 forms are not being sent in some browsers. It is only the “traffic circle” – that is something is in work.

    It affects the following browsers = IE11, Opera 45, Chrome 59. In Firefox and Safari funtkioniert the sending without problems.

    I have tried it with and without additional plugins for CF7, so it is not so. (Contact-form-7-datapicker, contact-form-7-to-database-extension, contact-form-7-dynamic-text-extension)

    Does anyone have any idea or solution to this problem. If I find something, put it here.

    I think this problem should not only occur with my websites or?

    Greeting Lawless-Diablo

Viewing 15 replies - 16 through 30 (of 41 total)
  • Thank you so much @bsteinlo.
    I have tried with aditional settings (on_submit: ….) and with DOM events (wpcf7submit) but I guess I’ve done it wrong (I’m not a programmer).
    I’m going to try to rollback to CF 4.7 and don’t eliminate the previous forms that I have.
    Thanks.

    At the end….it works!!!!
    With this plugin (WP-Rollback, https://wordpress.org/plugins/wp-rollback/) I’ve installed CF 4.7 (instead 4.8, thanks @bsteinlo) and the problem doesn’t exist yet (obviously making a backup before).
    Thanks.

    Just beware!

    When you delete 4.8 and upload 4.7 your form is reverted to default and the reCAPTCHA keys are lost. Back them up before downgrading.

    I call this a bug.

    • This reply was modified 3 years, 9 months ago by sarumbear.
    • This reply was modified 3 years, 9 months ago by sarumbear.

    Ok @sarumbear, thanks for your warning. In fact, I hadn’t reCAPTCHA on my forms but now I’ve included it.

    How is there still no fix for this? CF7 now has an update for 4.8.1 and the conflict still persists.

    I agree. CF7 had been a rock of the WP pluginsphere. Lately they dropped the ball.

    Testing on iPhone and iPad is not exactly difficult either…

    • This reply was modified 3 years, 9 months ago by sarumbear.
    • This reply was modified 3 years, 9 months ago by sarumbear.
    • This reply was modified 3 years, 9 months ago by sarumbear.

    4.8.1 still doesn’t work if you disabled the WP REST API like we did with https://wordpress.org/plugins/disable-json-api/. The request now uses the API, which returns a 401 if you’re not logged in.

    I left a suggestion for the author of https://wordpress.org/plugins/disable-json-api/ to enable whitelisting API endpoints so we could get the two plugins to work together here: https://wordpress.org/support/topic/restrict-plug-in-use-of-rest-api/#post-9396702. Chime in there if you’d like it to happen.

    +1 to this!

    Updated to the contact form 7 version 4.8.1
    WP version is also 4.8.1
    When tupping submit – redirect to previous page (with url adding /#wpcf7-f15557-o7)
    When came by direct link on the page with the form (no previous page) and click submit – no redirect.

    I downloaded the WP ROLLBACK plugin. Worked perfectly, thank you!

    Thread Starter Lawless-Diablo

    (@lawless-diablo)

    It works again, do not know why.

    Can anyone following this thread confirm that version 4.9 works with anonymous rest api access disabled?

    Edit: Never mind my question, I was logged into the site I was testing.

    • This reply was modified 3 years, 8 months ago by John Huebner.

    Same for me too, CF7 4.7 is ok, bigger versions fail

    but it happens ONLY for localized pages (WPML): form in default lang page is working fine, in translated pages the wheel keeps on spinning after submit

    I had the same problem with the latest version 4.9.

    In my case I was using the Disable REST API plugin to block all REST calls.

    If you have the same setup you can fix it by:
    1. Go to Settings -> Disable REST API
    2. Click on the checkbox near /contact-form-7/v1 (at the top level), the four sub-levels should become checked automatically.
    3. Click on Save Changes
    4. Sign out

    If you test it now it should work.

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘Contact Form 7 (Version 4.8) – Sending does not work’ is closed to new replies.