Support » Plugin: Contact Form 7 » Contact Form 7 (Version 4.8) – Sending does not work

  • Resolved Lawless-Diablo

    (@lawless-diablo)


    Hello

    I have just found that the CF7 forms are not being sent in some browsers. It is only the “traffic circle” – that is something is in work.

    It affects the following browsers = IE11, Opera 45, Chrome 59. In Firefox and Safari funtkioniert the sending without problems.

    I have tried it with and without additional plugins for CF7, so it is not so. (Contact-form-7-datapicker, contact-form-7-to-database-extension, contact-form-7-dynamic-text-extension)

    Does anyone have any idea or solution to this problem. If I find something, put it here.

    I think this problem should not only occur with my websites or?

    Greeting Lawless-Diablo

Viewing 15 replies - 1 through 15 (of 41 total)
  • Confirm. The same problem

    • This reply was modified 3 years, 11 months ago by iTRON.

    Same problem, but with FireFox (53.0.3). Emails get sent, but stuck in “Send” mode.
    Works correctly in Chrome (58.0.3029.110).

    It seems like it’s not consistent. Sometimes, the message goes through, and sometimes I just get the traffic-circle and nothing more, which has made troubleshooting a challenge.

    I’ve had it fail in Firefox (53.0.3) and Chromium. There are no PHP errors in my error logs, and Rolling back to CF7 4.7 fixes the problem. Updating to 4.8, and the problem is back. It seems like it may be a javascript issue with the changes in 4.8, but there are no javascript errors in my console, either.

    I tried updating to WP 4.8 to see if that helped, but no joy. The interesting thing is that if I log in using an admin account, submitting the form works every time. That means it could be a caching issue for me, since caching is disabled when I’m logged in. Checking into that now…

    Disabling the caching plugin didn’t help. Still had the unending traffic circle icon. All the file permissions look okay, too.

    I downgraded to CF7 4.7, and verified that the email form submitted just fine with no errors in the error logs running WordPress 4.8, so downgrading to CF7 4.7 looks like a reasonable temporary workaround even if you want to upgrade WP to 4.8.

    On a test site running WP 4.8 and no plugins other than CF7 with the TwentySeventeen theme, I have done some more testing. CF7 4.8 works fine on the clean test site until I add the ShieldSecurity plugin. When I add and activate Shield Security, then log out of admin (logging out of admin is required to get CF7 to fail), CF7 will no longer send the email form, just spinning the traffic circle icon indefinitely. When I deactivate the Shield plugin, CF7 works again. I haven’t been able to find any Shield settings that might account for the conflict. As before, there are no javascript or PHP errors.

    I don’t have all the modules in the ShieldSecurity plugin activated, but I did some further testing and identified the module in it that was causing CF7 form sends to fail. It turned out that if I checked “disable anonymous REST API” in the Lockdown module, CF7 fails. If that option is unchecked, CF7 works.

    Note that the only two modules I tested were the Firewall and Lockdown modules, because those are all I use.

    This might explain why testing CF7 while logged in allows it to work, and it doesn’t if I’m not logged in.

    Same problem here. Security plugin + CF7 is no longer working.

    Try rolling back to CF7 4.7, seems to be a REST API bug in the newest version, hope this helps!

    It’s certainly caused a lot of problems, but I’m not sure it’s a bug; CF7 4.8 “added custom REST API endpoints for Ajax form submissions”, and if you’re using a security plugin that disables anonymous REST API access, or have disabled it otherwise, your forms aren’t submitted unless you’re logged in. Rolling back to CF7 4.7 does fix it, and CF7 4.7 appears to work just fine with WP 4.8.

    Ah, that makes a lot of sense. I do in fact disable anonymous REST API access for security reasons. So, I suppose it’s not a ‘bug’ however this should be considered with a CF7 4.8 update, as a lot of people have anonymous REST API access disabled for security reasons.

    @bsteinlo – I completely agree with you. I really hope the developer makes it possible to use CF7 with anonymous REST API disabled, because CF7 is the best contact form plugin I’ve found.

    Agreed. This article says that enabling REST API is a big no-no.

    http://wpcerber.com/why-its-important-to-restrict-access-to-rest-api/

    I have read your comments and I have the same problem CF 4.8 + WP 4.8 = circle during a while … but in my case CF7 works (the form has been sent and received in a few seconds).

    I have been thinking of two solutions: one is rollback to CF 4.7 but I don’t know how can I do this (there is a plugin that rollback to a previous version but I don’t this plugins installed). The other solution could be: can I include an script (I don’t know if it’s possible in PHP, JS or another…) that, for example 10 seconds after I push the submit botton, can redirect to another page?

    My programming skills are very low 🙁

    @ramnic you can download previous version here: https://wordpress.org/plugins/contact-form-7/advanced/

    Just scroll down and select the version you want, in this case 4.7 should do it.

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘Contact Form 7 (Version 4.8) – Sending does not work’ is closed to new replies.