WordPress.org

Support

Support » Plugins and Hacks » Contact Form 7 » [Resolved] Contact Form 7 (v.3.2.1) Required Fields not working properly

[Resolved] Contact Form 7 (v.3.2.1) Required Fields not working properly

  • I was using v.2.4.6 on one of my client sites and had problems with required fields being submitted successfully with no input so I upgraded to the latest version (3.2.1) and I am having the exact same problems. There are also reports of lots of spamming coming through.

    The shortcode I am using for my form is:

    <div id="enquiry">
    <p>Send us your details and we will get back to you.</p>
    <p>[text* your-name id:name "Name"] </p>
    <p>[email* your-email id:email "Email Address"] </p>
    <p>[text* telephone id:telephone "Telephone"] </p>
    <p>[text* postcodeContact id:postcodeContact "Postcode"] </p>
    
    <p>[textarea* enquiry id:enquiry-field "Your Enquiry"] </p>
    <p>[submit class:cta_send "" ]</p>
    </div>

    Has anyone else had this same problem? Or any other problem related that might fix this in hindsight?

    http://wordpress.org/extend/plugins/contact-form-7/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Takayuki Miyoshi

    @takayukister

    Try deactivating all other plugins and switching to the default theme.

    Thanks Takayuki.

    I managed to figure out what the problem was. The ‘Default Value’ was being considered as a value, therefore passing the validation on all but the Email Address. A simple fix but it means I have to amend the design of the site for labels where I had not intended to use them in the first place.

    Major problem IMO when using this plugin, despite how useful it can be at times.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Contact Form 7 (v.3.2.1) Required Fields not working properly’ is closed to new replies.
Skip to toolbar