WordPress.org

Support

Support » Plugins and Hacks » Contact Form 7: Spinning arrow.

Contact Form 7: Spinning arrow.

  • Once my readers click submit on various CF7 forms within my website, they’re getting an infinitely spinning arrow.

    The data is still delivered to my inbox, but they don’t know that, so they keep on trying and I end up receiving the same content over and over again.

    You can find forms here and here (towards the bottom).

    I wonder if it has something to do with the quick fix I implemented when I had this problem a month ago. I’ve tried to reverse this, but the code seems to have changed.

    I’m not good with js, so please be gentle with describing any theories or explanations 🙂

    Incidentally, I used to have no problems at all with CF7 but recently things have started to go wrong and I’m not sure why? I haven’t changed anything other than the ‘quick fix’ I linked to above.

Viewing 15 replies - 1 through 15 (of 25 total)
  • I too am stuck with the eternal spinning arrow. I had this problem with the old version and also used the same fix.

    But now with the update, I am also at a loss. The email still gets sent, but the ajax doesn’t load to tell the sender that.

    Any Suggestions? Or should we do a clean install of the plug in?

    I have the same problem :(, can anyone help us? Thanks in advance!

    Okay I tried a clean install of the plug in, same problem.

    So I finally just got my old copy of the plug in, reinstalled that and did the quick fix and got it working again without the ajax.

    I’d rather have a working form with some kind of confirmation rather then 100’s of duplicates in my email.

    How did you change the script in scripts.js? They seem to be different for me — I just wanted to reverse the fix and see if that fixed it.

    I had the same some time ago and again today. Both times seemed to have been related to the site being hacked. After a clean up everything when back as it should. Locally I was not been able to access WP Admin even after cleaning the installation. I removed CF7 and all is well. I noticed there’s an update to CF7 and will try it again because I like it but will keep an eye on it.

    You may want to visit this site about the latest hack

    http://blog.sucuri.net/2010/05/new-attack-today-against-wordpress.html

    @hardwork64: I don’t think that has anything to do with my problem.

    Fred

    @fredoptimaldesignstudiocom

    I’m having the same problem with the spinning arrow using 3.0.1 and Version 2.4.1 Contact Form 7. I have uninstalled every plugin (even deleted them all.) Still spinning. I receive the emails with attachments. What versions did you revert back to PaperRemption? I would like to try that.

    It seems a lot of people are having this problem, but there’s no support from the author.

    Perhaps they’ve lost interest — so instead of sitting here waiting for answers, I’m wondering if anyone knows a good alternative plugin?

    @trailofants
    Have you tried removing the Second Contact Form? Maybe its in the sidebar. But having two within the content could cause issues.
    Also just do a quick test and try with the Twentyten theme for a minute.
    I have Contact Form on hundreds of sites without any issues. Have more trouble trying to duplicate the problems that get reported 🙂 One of the most reliable plugins I use.

    FOR ANyone else, would help have a link to your contact form.

    Thanks Webjunk — I’ve taken it off the sidebar, but still the same problem on /contact and other pages.

    I also reverted temporarily to TwentyTen, and unfortunately the problem remained.

    I have a suspicion that the core of my problems is rooted in this line from my original post:

    “I wonder if it has something to do with the quick fix I implemented when I had this problem a month ago. I’ve tried to reverse this, but the code seems to have changed.”

    Thanks again for your suggestions.

    WOuld really like to nail this down if you don’t mind.
    Can you provide the following:
    WP Version:
    CF7 Version:
    Hosted on Windows or Linux?
    Apache or IIS?

    Make sure you have undone the “quick Fix”
    then in the plugins /Contactorm7/wp-contact-form-7.php
    take out the “!” so it should be like:

    if ( defined( 'WPCF7_LOAD_JS' ) )
    
    	define( 'WPCF7_LOAD_JS', true );

    Thanks for trying to help, webjunk.

    WP Version: 3.0
    CF7 Version: 2.4.1
    Windows or Linux: Not sure, how could I find this out for you?
    Apache or IIS: Again, not sure.

    I’ve followed your suggestions, including removing the “!”, but the problem remains.

    If I can help you help me, let me know.

    Fred

    @fredoptimaldesignstudiocom

    With WP 3.0.1 I was able to get the form to work by deleting the 7.2.4.1 install and loading 7.1.9.2.2

    It works fine now. Hope this helps someone.

    Upgrade WP to current 3.0.1
    May not fix this issue but its almost impossible to support new plugin with older version of WP for which it was designed. Update that before going any further.

    @fred
    GOing to a much older version is not a fix. There are many fixes in 2.4.1 (some might be security related) and you are eliminating them. The current version works with the current version of WP. At least on a few hundred sites I work on 🙂 If 2.4.1 is not working then you have other issues.

    Sorry about that Fred. Yeah I had to go back to the 2.2 version of Contact Form 7, and do that quick fix. (although when I just went to check apparently I updated it without knowing it.) The quick fix is still in use, otherwise just a spinny arrow.

    @webjunk
    WP Version: 3.0.1
    CF7 Version: 2.4.1
    Windows or Linux: Linux
    Apache or IIS: Apache

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Contact Form 7: Spinning arrow.’ is closed to new replies.
Skip to toolbar