Support » Plugin: Contact Form 7 reCAPTCHA Extension » contact form 7 + recaptcha not working

  • coffeepug

    (@coffeepug)


    New to WordPress, signed up yesterday and currently trying to create a contact form.

    Used contact form 7 and got that working no issues but then decided to use the suggested recaptcha to aid spam and bots..

    followed the guide and its not working… goggled this and read endless threads about others struggling and im at the point now where i am considering getting rid of contact form 7 and recaptcha unless i can get help…

    – got both sets of google keys and integrated them
    – added [recaptcha] just before the submit button on the form using the button and selecting light etc

    wont load..

    help

Viewing 15 replies - 16 through 30 (of 33 total)
  • Yes, I did this same thing and it worked for me!

    Yes, but does it work correctly on EVERY device out there???

    I had constant reports from customers who said they were entering the right code but it still wouldn’t let them send the form after they filled it all in. I discovered this usually happened on ipads or iphones or safari, I eventually got it working and tested on all these devices but it was an intermittent problem. I then noticed it had stopped working on my Samsung (Android) using Chrome. With customers being so impatient these days it simply wasn’t worth the risk of missing out on orders. A few had taken the time to report the problem to me but I wonder how many others simply gave up and went to a competitor instead.
    Not worth the risk!
    I’d rather have a few spam emails come through than miss out on orders and annoy my customers with yet another captcha. So I got rid of the captcha, rather than spend yet another day searching for answers to my never ending problems with my website.

    If anyone has a better idea I’m all ears 🙂

    Just fyi — It works fine on my iPhone (using Safari) & my Kindle Fire.

    Worked fine for me for about 2 years! Then I started getting reports. One less thing I have to keep an eye on.

    I had a problem recently with my recaptcha.
    It would still send the form without checking the ‘are you a robot’ checkbox.
    And all the settings were correct, using Avada theme. In the end it didnt matter if the page template was set to contact page or 100%width

    In order to fix this in my contact form code.
    located at – wordpress dashboard – contact – contact forms

    I had to add the [recaptcha] widget like so in order for it to verify that the box is indeed checked before the form was sent. With out this it would send the form anyway. Hopefully i get less spam now

    <table>
    <tr><td>
    <div class=”g-recaptcha” data-sitekey=”yoursitekey”></div>
    </td><td>
    <p>[submit “Send”] [recaptcha size:compact]</p>
    </td>
    </tr>
    </table>

    Hope this helps someone out there.

    [recaptcha size:compact] appears in form next to Send button. Is this normal?

    Looks like I had the same issue as gymreading.

    My key was somehow copied incorrectly. Once I re-copied and made sure that the code was correct. It started working!

    I had this problem too — solved it by reading gymreading’s post above. I design with a mac, using Chrome. I generally use the Mac keyboard shortcuts for copy (apple + C) and paste (apple + v). When I copied the the site key from the Google Captcha page using my keyboard short cuts, it copied and pasted just fine into word press. For reasons I do not understand, when I did the same thing for the secret key, it did NOT copy the code. So I was pasting the last thing it did copy into the secret key field, without knowing it. Of course this was causing reCAPTCHA to fail.

    The fix was to copy the secret key code using the “copy” command under the “Edit” menu with my mouse, and then pasting using the “paste” command under the “Edit” menu with my mouse.

    I Don’t know why this was happening, but it’s fixed now and working just great. Another happy customer. Hope this helps someone!

    I’vce got the same issue after moving my website to another server. As a result the ip address had been changed. It’s 24 hours ago but the google reCaptacha service still not know that the ip address changed, so it is not working at all.

    Hope it gets resolved after a few more days.

    Having a similar issue. ReCAPTCHA has been working fine on Chrome, but some IE11 users are experiencing problems – specifically after passing through the reCAPTCHA the Contact 7 form will not allow them to press the SEND button. Some google searches pointed to the Microsoft Compatibility Settings as being the culprit but I could not get it to work and don’t have time to troubleshoot. Will temporarily remove reCAPTCHA until a solution is found, and/or use another plugin.

    Still nothing? already tried all the posible solutions in this topic and can´t get it work in any browser 🙁

    I also could not make it work forever … did not see the <script src=’https://www.google.com/recaptcha/api.js’></script&gt; and / or <div class=”g-recaptcha” data-sitekey=…. in the source code of the form generated from the word press and contact form 7.

    Rechecked keys , permissions, … still nothing.
    Thinking that one of the plug-ins was messing it somehow I disabled them all one by one but still no luck.

    Then I tried a different theme and bingo recaptcha worked.
    Back to Atahualpa (3.7.24) and it did not work again.
    Resetting ALL theme options fixed it. I’ve just had to configure Atahualpa again.

    My guess is that some very old option, hack or other mess was doing this.

    @dubiz84 soluction worked for me, nothing more did the job.

    I’ve put de google div code in the end of the form like this:

    <div class=”g-recaptcha” data-sitekey=”yoursitekeyxxxxx”></div>

    And, for aditional, i’ve put the script of the google recaptcha client side integration on my theme’s head:

    <script src='https://www.google.com/recaptcha/api.js'></script>

    Now recaptcha is working and has to be clicked so the form can be send. The only thing “weird” is that contact form 7 does not tell that the error to not send the form when I don’t click in captcha is because it was not marked, it says only that it got an error to send the form. But I can live with that.

    I was having the same issue, I did what gymreading did and re-copied the recaptcha codes from google and then it all worked 🙂

    Okay — This might not be the solution to your problem, but it was the solution to mine:

    When I copied my secret key, I double-clicked to select the whole thing. Google’s page is somehow set up so that if you double-click on the key, you also get the next darn line of text (in my case “Step 1. Client side integration”)… So I was entering aaall that as my key, which of course made it fail.

    Once I entered my key correctly, everything worked fine. Hope this helps everyone else.

    THIS WAS MY PROBLEM TOO 🙂 . Thanks Gymreading

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘contact form 7 + recaptcha not working’ is closed to new replies.