Ready to get started?Download WordPress


Contact Form 7 Producing Blank CAPTCHAs (15 posts)

  1. jasewatson
    Posted 3 years ago #

    Hello everyone =) So I am using Contact Form 7 (CF7) on a few different WP installations, but on my latest one it seems as though CF7 is producing blank CAPTCHAs everytime the page is requesting the attached form.

    Before it's mentioned, YES, Both GD and FreeStyle libraries are installed on the server being used (obviously I should have realized this before calling my host since my other installs worked fine). Permissions are set for the /wp-content/uploads/wpcf7_captcha folder, the .PHP and .PNG files are generating correctly and are not corrupt.

    What gives? Is this a bug with 3.1.2 that needs to be fixed in the next ver. of CF7? Any help would be much appreciated. Thanks!

  2. Paddy Landau
    Posted 3 years ago #

    I have the same problem.

    See previous thread on this issue.

    The CAPTCHA used to work on my site, but it suddenly stopped. I wonder if it has anything to do with the recent updates?

  3. Paddy Landau
    Posted 3 years ago #

    I found the problem on my server. See my previous thread on this issue.

    I hope it helps you.

  4. jasewatson
    Posted 3 years ago #

    This issue has been resolved. The answer can be found at http://wordpress.org/support/topic/plugin-contact-form-7-captcha-image-does-not-display

  5. jasewatson
    Posted 3 years ago #

    Ok, so actually, that did not resolve my issue. I turned off hotlink protection via my cPanel and CF7 is still producing blank CAPTCHA images. Any other ideas?

  6. Paddy Landau
    Posted 3 years ago #

    Did it work previously, when you posted one week ago?

    I would suggest you double-check your .htaccess; maybe post it here if it's not confidential, so we can have a look.

  7. jasewatson
    Posted 3 years ago #

    Hey Paddy. It did not work. I jumped the gun and closed the topic without trying to see if turning of HotLink protection in cPanel would fix it.

    Here is the .htaccess file located in the sub folder for the domain that I am having issues with:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
    RewriteRule .*\.()$ - [F,NC]

    *Note: I went ahead and contacted my hosting support. The rep took a look at the file and said everything appeared to be normal except for the RewriteRule .*\.()$ - [F,NC] portion of the code. He recommended I try commenting that portion out with a '#' so I gave it a shot, but the problem persisted. Also, the way it seems set up there are .htaccess files for each domain hosted on the account in it's main folder, as well as an .htaccess file on the root of the server. I'm assuming it only pertains to this .htaccess though since it's inside the domain-in-questions directory. Any help would be much appreciated! Thanks!

  8. Paddy Landau
    Posted 3 years ago #

    The WordPress part looks fine.

    The line RewriteRule .*\.()$ - [F,NC] does look odd. I'm struggling to understand its purpose. If I have understood it correctly, it is a poorly-written command to say that any URL ending in a dot (e.g. www.example.com/abc.) will fail. See the Apache reference on regexp.

    I would comment out this line (add a # at the beginning of the line), or just delete the line.

    On some servers, it can take a few minutes to show up changes to your page -- or, your browser may be remembering the previous result. So, make your change to .htaccess; wait five minutes; clear your browser's cache; then try again.

    If you want to prevent hot-linking, try this code (replace example.com with your domain name excluding the www.), and place it before the WordPress section in .htaccess.

    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http://(www\.)?example.com [NC]
    RewriteRule \.(jpg|jpeg|gif|png|bmp|pdf)$ - [NC,F,L]

    Let us know if this helps.

  9. jasewatson
    Posted 3 years ago #

    So after about 24 hours having commented that line out still nothing. The CAPTCHAs are still being produced blank.

    Next idea? Haha.

  10. Paddy Landau
    Posted 3 years ago #

    I'm sorry, I don't know what else to suggest. I'm hardly an expert with these things. Try contacting your host's support; with luck, the support person will have some idea. Also Google for this problem.

    Oh yes, one more thing. Each directory inherits its parent .htaccess (which in turn inherits its parent's one). Whenever there is conflict between two levels, the lowest level takes priority. So, check all the .htaccess files (if any) between / (your root directory) and /wp-content/uploads/wpcf7_captcha inclusive.

    Good luck. I hope you find the problem.

  11. Threecows
    Posted 3 years ago #

    Did you try to uncheck the option: Use CAPTCHA without PHP session ?

  12. jasewatson
    Posted 3 years ago #

    @Threecows Where is that option? To my knowledge, neither CF7 or Really Simple CAPTCHA have settings pages. (Well, CF7 has a link called "Settings" but that just leads to the form setup page.)

  13. Threecows
    Posted 3 years ago #

    Sorry, my mistake.
    Thought this was about Fast Secure Contact Form, which is btw a good alternative.

  14. jasewatson
    Posted 3 years ago #

    Alright. So I contacted my hosting tech support and after about 45 min. we determined that an unknown file that is part of the plugin is not properly calling the .php script associated with its correct image file. The image file is being called on correctly, but the file that is calling the image is not calling the script correctly. Unfortunately, I will have to move on to another plugin. I'll leave this thread marked as unresolved so that perhaps someone else that experiences this problem will be able to work from where we've gotten and provide a solution that will close this thread. One word of warning for the next few people to read this thread: make sure that the directories that house ANY AND ALL files pertaining to the operation of CF7 have 755 permissions. 777 will pretty much setup the plugin to overwrite its own files and kill itself. I tried to reinstall the files to the server with 755 permissions rather than 777 (which was set by some incompetent other support guy) but still no luck.

    Wish the next person(s) well! =)

  15. Paddy Landau
    Posted 3 years ago #

    That sounds bizarre, Jase. Good luck with finding a replacement.

Topic Closed

This topic has been closed to new replies.

About this Topic