• Resolved frenchomatic

    (@frenchomatic)


    Not sure what is going on but here is my set up and I have only started having problems fairly recently.

    WordPress Version 5.7
    WP-Optimize Version 3.1.8
    Contact form 7 Version 5.4
    NinjaFirewall (WP Edition) Version 4.3.2

    What seems to happen is whenever there is an update of Ninja rules my contact forms stop sending emails. This goes away after I use WP-Optimize to clear the cache. Unless I clear the cache emails get blocked.

    In Ninja (great plugin by the way), I have the options off that you recommend

    Through the WordPress REST API *. is OFF
    WordPress REST API Block any access to the API *
    XML-RPC API Block any access to the API * is OFF
    Block system.multicall method *

    I am fairly competent and I have not been able to track the problem down. I am going to disable WP-optimize and wait for the next rules update and see what happens. Not sure if you can any other advice or thoughts why it is doing this.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author nintechnet

    (@nintechnet)

    Did you check the firewall log if there was anything related to this issue?
    You can also enable WP_DEBUG in WordPress and check the PHP error log for any notice, warning or error.

    Thread Starter frenchomatic

    (@frenchomatic)

    Nothing in the firewall log. Nothing showed in WP_DEBUG either. I will turn that on if the problem returns. I had no problems yesterday. I have just included a new SMTP plugin which should give better reliability and excluded pages with contact forms on them from being cached. I will wait for the next ninja rules update and test again.

    You may want to downgrade to Contactform 7 5.3.2 as there is a bug in 5.4 (check the browserconsole for errors). This happens due to some caching related issues (don’t combine js files).

    You can use https://de.wordpress.org/plugins/wp-rollback/ to downgrade to the right version.

    Thread Starter frenchomatic

    (@frenchomatic)

    Thanks – I did that and all works. However, I ended up deactivating wp-optimize and implemented a fantastic solution by wp cloudflare super cache – all is working.

    • This reply was modified 3 months, 2 weeks ago by frenchomatic.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.