Support » Plugin: WP-Optimize - Cache, Clean, Compress. » Contact form 7 – possible plugin conflict

  • Resolved frenchomatic

    (@frenchomatic)


    A nice plugin which I have used for some time. However I am now having an issue with contact form 7 where I am getting the spinning wheel effect. It seems related to the caching feature of wp-optimized although it is proving hard to say with certainty.

    (i.e. I don’t see anything in error logs etc as to what is happening when the wheel spins and the from fails to submit).

    I am using wordpress 5.7, CF7 version 5.4 and the latest version of WP-Optimize. It is doing this on several different web sites which are also using different themes.

    I have excluded pages with contact forms from being cached as I thought this may be a problem but it makes no difference.

    The spinning wheel seems to come randomly but I do notice things get fixed when I manually clear the cache of all pages.

    Is there anything else apart from excluding those pages from being cached to set up on the wp-optimize plugin? One other thing is I do run CRON from my server and not from wordpress.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Harshad

    (@bornforphp)

    @frenchomatic Can you please try to disable Process HTML from WP-Optimize > Minify and check if it helps to fix the issue?

    Thread Starter frenchomatic

    (@frenchomatic)

    Thank you for your reply but I am not using minify at all.

    Thread Starter frenchomatic

    (@frenchomatic)

    As an update – when I deactivate the plugin, contact form 7 appears to work.

    I begin to wonder if it has something to do with “nonce” and how often the cache is refreshed (even if the contact pages are excluded from the cache).

    Thread Starter frenchomatic

    (@frenchomatic)

    Another update – if the plugin is activated but page caching is turned off, things seem to work. It is not suffice to only exclude the pages with contact forms on them. Minify is also turned off as I don’t use that functionality at all.

    • This reply was modified 3 months, 4 weeks ago by frenchomatic.
    Plugin Support Harshad

    (@bornforphp)

    @frenchomatic Can you please try to exclude the page url from WP-Optiize > Cache > Advanced settings, where contact form 7 is added for now, so that the form works.

    I’ll check this with our development team to see if there’s compatibility issue with the latest update of Contact form 7

    • This reply was modified 3 months, 4 weeks ago by Harshad.
    Thread Starter frenchomatic

    (@frenchomatic)

    Yes I tried that but it still didn’t work. I have deactivated the plugin. If you find anything then I will try a test.

    Greetings – Just want to report that I too am seeing the same issue as frenchomatic regarding lack of compatibility with Contact Form 7.

    Contact Form 7 is only submitting once page cache and minify are turned completely off in WP-Optimize settings or the plugin is deactivated.

    Hello, just wanted to report i have the same issue as it was describe. i tried all the things with deactivating and activating features, but there seems to be a conflict between CF7 and WP-optimize. We have to deactivate Wp-optimize, which is quite a loss for our site speed.

    Thread Starter frenchomatic

    (@frenchomatic)

    I gave up and just deactivated wp-optimize. I now use a great plugin called wp cloudflare supercache – no problems at all.

    Just to thank everyone here for reporting the conflict and we are prioritising a fix, and will report back shortly.

    Plugin Author David Anderson

    (@davidanderson)

    This was fixed in WP-O 3.1.10 – please open a new topic and let us know if you still see problems. Thank you!

    David

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.