Support » Plugin: Contact Form 7 » Contact form 7 not submitting [Solved]

  • Resolved Solve

    (@solveweb)


    We have 100’s of websites that use contact form 7. Our customers are experiencing that the submit button is not working or delayed. However, we found that if we disabled caching on the contact form pages, the forms now submit!

    We have disabled WP rocket on those pages. Some people are saying roll back to a previous version.

    Hopefully Contact form 7 fix this soon. Let us know if there are any other workarounds. Thanks

    • This topic was modified 6 months, 3 weeks ago by Solve.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello,

    How do you disable the caching on the contact forms?

    Thanks.

    Same issue here. Disabling caching does not solve it. The email is sent, but something is lagging and no response message appears.

    Console error info on page load, and repeated when submitting:
    message: “The response is not a valid JSON response.”
    Failed to load resource: the server responded with a status of 404 ()
    /contact/contact-form-7/v1/contact-forms/5/refill?_locale=user:1

    I have not changed anything in my json disabling settings, and let through all cf7 json endpoints. This worked fine in the previous cf7 version.
    Is there not a way to just optionally disable refill and feedback functions, they give more problems to me than they solve.

    @solveweb , please remove [Solved] from the title 🙂
    @ericharris19 , just exclude ‘contact’ pages in your cache plugin exclusion list.

    Gonna rollback now. Thanks.

    I’ve the same problem, any submitting, i’ve solved temporary with deactivation of reCAPTCHA in my CF7. Any solution please? thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Contact form 7 not submitting [Solved]’ is closed to new replies.