WordPress.org

Support

Support » Plugins and Hacks » Contact Form 7 not sending emails- no confirmation, no error

Contact Form 7 not sending emails- no confirmation, no error

  • I’ve noticed that Contact Form 7 recently stopped working, despite my not having touched any of the settings. What’s odd is that I receive neither a confirmation nor an error message; I click “send” and nothing happens. This problem persists across FF, Safari, and Chrome.

    I read in other, older threads that it could be something to do with SMTP settings, but as the threads were 2 years old, most of the work-around plugins they suggested are no longer an option.

    Any ideas?

    Also, once the problem is fixed.. is there any way for me to obtain the lost email? I use the form for my business site and have undoubtedly lost leads because of this..

    WP 3.4.2
    CF7 3.3.1

    http://wordpress.org/extend/plugins/contact-form-7/

Viewing 15 replies - 1 through 15 (of 47 total)
  • ETA: I’ve just found this patch and tested it out- I’ve noticed no changes in the functionality of the form(ie- it still doesn’t work).

    Same problem here. I have contact forms on multiple websites and domains and they have all stopped working abruptly. I have done the following:
    – reinstalled plugin
    – deactivated all other plugins
    – created a new subdomain and only installed contact form 7, and same issue.
    – installed other contact form plugins and they work fine
    – changed email to several other email addresses (yahoo and aol)
    – checked my mail log and shows they are being sent.
    – Called my hosting service (godaddy) and they show emails as being sent, but they gave me the wordpress.org forums link. grrr.
    – I installed the WP-Mail-SMTP plugin and tried mailing using smtp, but nada.

    Talk about frustrating. The issue is specific to contact form 7, but how I have no idea.
    Any outside the box suggestions?

    sebasvisser
    Member

    @sebasvisser

    It’s poop! Poop I tell you…

    anyways, same problem here, I did manage to find my lost emails by going into the ftp and into the folder MAILDIR/new open those files with notepad or notepad++
    Looking at those files the trouble started around the 25th of october with some mails being blocked, and around today with all mails from contactforms being blocked…

    havent found a way to fix it yet though..
    btw im on Dreamhost

    I have contacted my hosting support and they show the forms being sent, but still nothing received. I then tried other forms like quick contact, ajax forms etc. The only one that works is quick contact form. As a bandaid, this is fine. But I have some very in depth forms that arent easy to duplicate. Im guessing its a godaddy thing, but they dont know what it is. Im just stymied that quick contact form works but cf7 doesnt.

    same problem here..
    I’m hosting with JustHost.com and some of the CF7 forms are not working ok.

    Maybe it’s a different issue? If I submit a form with the email, for example gery@yii.co.il I will get the “cannot send error”. but if I use gery@gmail.com or anything else it will work ok.

    what’s about “yii” domain that will not work?

    thank you in advance!

    my site

    sebasvisser
    Member

    @sebasvisser

    I gave up on this and just made me a pretty form in jotform.
    that still seems to work. I cant have my customers wait without contact and registration forms

    I’m having the same problem. The Contact form appears to work and I get a successful response but the email never hits my inbox and it’s not in my spam/junk folder.

    I changed email addresses to send the contact form info to and that didn’t make a difference.

    I haven’t made any changes to my site no activated/installed any new plugins.

    It looks like I stopped receiving emails 11-15-12 in the am.

    I don’t know what else to do. Where is the MailDir folder within the WordPress site. I can’t seem to find one or is that hosting provider specific. I’m with Goadddy.

    Thanks,
    mr

    T Klein
    Member

    @tklein87gmailcom

    I am on dreamhost, same problem. Very hit or miss whether the email sends or whether or not the submitter gets CC’d like he is suppose to. I’ve emailed Dreamhost multiple times yet they don’t know the problem and just say their is nothing in the mail logs.

    Doesn’t make sense, I use contact form 7 to DB also, and everything gets logged into the database fine, but the mail doesn’t send sometimes.

    Hope someone finds out the problem.

    Wow, I’m quite surprised to see such a reputable product/plugin giving so many people the same trouble. I’ve noticed in the past, the developer has been rather responsive.. maybe there is hope. If not, I fully plan on using the Pods Framework.

    I’d recommend Gravity Forms if you need a CF7 replacement. Pods is probably overkill for contact forms.

    I have the same problem on a handful of sites. First it was one, now another, now I am checking all of them and a bit frightened that I will have a lot of work to do recreating forms! (lottsa sitessss ya)

    I use CF7 to Database Extension plugin and all submissions are there (thank goodness!) but nothing coming to inboxes. Very very frightening Galileo. Have tried all sorts of troubleshooting. This is on DreamHost. I have other site on VPS.net and the forms are working, it seems. Very good, I am one step closer to understanding this perplexing issue.

    Also I think it’s noteworthy to quote this person from this other post:

    keyaspects
    Member
    Posted 3 days ago #

    I’m having the same issue with any email address hosted by google. i,e, gmail.
    The mail doesn’t even make it to my inbox / spam / junk folder. Seams to get highjacked by the server at some point.

    Private ISP email address work fine – comes through to the inbox no problems.

    I don’t have a Private ISP email address to test this out on right now, but that’s interesting. VPS.net does things differently than DreamHost.

    Maybe there is something to do with DreamHost’s and other general shared hosting providers’ mail servers that don’t digest well CF7’s headers or something like that.

    My hope is for Takayuki Miyoshi to have insight as to why this is happening, or somebody more knowledgeable than me on reading email logs etc. Thing is, the plugin is sending the emails … and I’m pretty sure the plugin uses WP’s built-in email engine, whatever that is .. some simple PHP thing, I think … so … what is the problem???? this is what confounds me .. and keeps me awake right now.

    A few more details .. I have a plugin that tells me whether or not emails are sent .. it says they are. I try changing email addresses in CF7 .. no lucks. Fast Secure works, Jetpack works .. sometimes I wonder, did another Jetpack upgrade knock out my CF7?? I disable Jetpack. Still no CF7 luckys in the box. I remember once talking with DH support about it and they referred back to plugin or WP. Now I am wondering, could it be a core WP update that got me? Jquery versions not jivin or some sort … trying to remember what else that killed of mine .. oh yeah an image slider. Was it me that put two jquery’s in there, or did WP add that? Using child themes on twentyten, did I update twentyten? in 2012? Na hhh.. could be WP core though? Injecting a little jquery into my heads?? Not even sure if CF7 uses jquery ////

    ALSO I should note, that unlike the original poster, my forms do give the GREEN checkmark that implies success, ‘Thanks for your submission.” etc. So that’s good .. just not getting to the inboxes, somehow.

    Same problem here.

    Mika Epstein
    DreamHost Rep

    @ipstenu-dh

    It’s possible our anti-spam measures at DreamHost are causing problems.

    You can fix CF7 with the WP SMTP plugin: http://elftest.net/contact-form-7-and-anti-spam/

    Wooohooo!!!!!! Great answer!

    Except I must have to set some of the settings, I get an error now when trying to submit the form:

    “Failed to send your message. Please try later or contact the administrator by another method.” – CF7

    When in the plugin settings, I can do a test send; it says:

    An error was encountered while trying to send the test e-mail.

    SMTP Error: The following recipients failed: info@mywebsiteURL.com

    SMTP server error: 5.7.1 : Recipient address rejected: Access denied

    Maybe SMTP settings have to not be ‘localhost’ but instead something DH .. looking … (your blog post says all i had to do was enable .. I think maybe settings need adjustment?) .. looking …

    Thank you very much for the answer … DH love

Viewing 15 replies - 1 through 15 (of 47 total)
  • The topic ‘Contact Form 7 not sending emails- no confirmation, no error’ is closed to new replies.