Support » Plugins » Contact Form 7 is sending forms from blog email instead of submitter’s email??

  • Contact Form 7 (v 2.0) and WP 2.8.2 — sorry if this is a repeat question, but I searched and couldn’t find anything…

    Contact Form 7 (wonderful plugin!) is now replacing the FROM email which SHOULD be:
    [firstname] [lastname] <[email]>
    with the blog email ???

    Why was this changed from earlier versions?
    HOW do I get contact emails to again be sent ‘from’ the email as set up in the form??? This is important!



Viewing 13 replies - 1 through 13 (of 13 total)
  • @mike Nothing has been changed. I suppose there was probably another reason.

    I just noticed this too! :/

    My workaround for now is adding a Reply-to to the additional headers, something like this:

    Reply-to: [name] <[email]>

    I wanted to chime in and say this problem has come up for me as well with the latest update. I’ve double checked my fields, as well as possible plugin conflicts, but I’ve come up without a solution.

    WP – 2.8.3 and Contact Form 7 – 2.0.1

    As a follow up, my problem stemmed from a conflict with Simple:Press Forum. A modification to the forum plugin solved this issue.

    @fredandres thanks. It must be good info for other people having similar problem. Wouldn’t it be nice if you share how you modified and fixed that?

    I’m having this same problem! And, not coincidentally, I’m sure, it started just after installing the Simple:Press Forum. Please share the fix for this!


    I found i had this problem when i used some of the SMTP plugins for wordpress.

    What i did was remove the SMTP plugins and then just edit the SMTP information myself.

    Open the file wp-includes/class-phpmailer.php

    In the file you should find:


    In my file its on line 166.

    Below that you can edit the SMTP information for wordpress, just put in whatever your SMTP information is and save the changes.

    If that doesn’t work then i don’t know.

    FWIW – I’m having the same problem. Adding Reply-to: [your-name] <[your-email]> to the headers is providing a temporary fix.

    It just started happening with the most recent update.

    Hi fredandres,

    what a coincidence that I have the same problem and simple press forum installed? 🙂
    Please share your fix. It would help a lot of people!



    To everyone that have simple press installed and experience this problem:

    Go to Forum > Options > E-mail and uncheck the two boxes. That will resolve your problem.


    I don’t have simple press installed but have the same problem, any ideas?

    I have tried using SMTP plugin with it to no avail.

    I am getting an email from my blog email with NO details submitted from the form… Please help this is driving me crazy!

    Thanks 🙂

    Hi everyone, I got the same problem, I’m using WP-Mail-SMTP plugin to use smtp server to send my mailings, and use contactform 7 , I have noted when I receive the mail, it was sent from my own email address and not from the email subscriber.

    I don’t understand the solutions writed by “do77”:

    “Go to Forum > Options > E-mail and uncheck the two boxes. That will resolve your problem. “

    Anybody may explain to me how to fix this problem please?

    thanks in advance


    I’m having the same problem, I’m using wordpress mu 2.8.4 and the latest contact form plugin. No simple:press or smtp nonsense. I’m using the replyto workaround for now.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Contact Form 7 is sending forms from blog email instead of submitter’s email??’ is closed to new replies.