Support » Plugin: Invisible reCaptcha for WordPress » Contact Form 7 Error Message Everytime

  • Resolved WorldOfBenjamin

    (@worldofbenjamin)


    When I have this plugin enabled, every time I submit using contact form 7, all messages get blocked.

    The website is cosmovisionmedia.com Right now I have the plugin disabled as it’s causing this issue.

Viewing 15 replies - 1 through 15 (of 19 total)
  • I am getting the same thing. It appeared out of nowhere a few days ago. I do not know what the issue is but I have the issue on multiple types of servers and the only thing that looks similar is that it is showing with CF7 mainly. Some wp-login screens are not even loading the recaptcha logo.

    I tried this setting and it did not change the outcome.

    Plugin Author MihChe

    (@mihche)

    Hi guys,
    @phorbidden, @renoovodesign

    I’ve been working on this for few days now and I think I found a solution. Any of you would like to help me testing it before pushing an update?

    Thanks,
    ~Mihai

    I would love to.

    In the logs:
    PHP Catchable fatal error: Argument 1 passed to InvisibleReCaptcha\\MchLib\\Plugin\\MchBaseAdminPage::renderGroupModulesSettings() must be an instance of InvisibleReCaptcha\\MchLib\\Plugin\\MchBaseAdminPage, null given in ***/wp-content/plugins/invisible-recaptcha/includes/plugin/MchBaseAdminPage.php on line 286, referer: https://www.example.com/wp-admin/options-general.php?page=invisible-recaptcha-settings

    I got the latest update from Benjamin and it solved my issue. Not sure about that PHP error though. I am not seeing that.

    Plugin Author MihChe

    (@mihche)

    Hi @nuttwicrew,
    I’ve sent you the new version. Please let me know!
    ~Mihai

    @mihche

    I test plugin new version and I have problem some form it’s strange

    1. Submit the form the first time, it working
    2. Submit the form the second time (not reload the page) it not working and show alert box error message
    “Cannot contact reCAPTCHA. Check your connection and try again.”

    I check in Developer Tools on Google Chrome -> Network tab -> XHR
    The second form not send “grecaptcha.reset” after sumbit.

    I solve the problem by add on_submit: “grecaptcha.reset();” In Additional Settings tab

    • This reply was modified 1 year, 10 months ago by nuttwicrew.
    • This reply was modified 1 year, 10 months ago by nuttwicrew.
    • This reply was modified 1 year, 10 months ago by nuttwicrew.
    • This reply was modified 1 year, 10 months ago by nuttwicrew.
    Plugin Author MihChe

    (@mihche)

    Hi @nuttwicrew,
    Will you be able to change something in the plugin’s code if I’ll give you the instructions?

    Started getting the same error “Cannot contact reCAPTCHA. Check your connection and try again.”… Looking forward to a fix.

    Hello, same as above. is there a way to solve ?

    messages aren’t blocked, but captcha gives the same error:
    “Cannot contact reCAPTCHA. Check your connection and try again.”

    • This reply was modified 1 year, 10 months ago by coalas.

    Hello, i have same problem like this.

    @mihche
    Maybe add this code

    document.addEventListener( 'wpcf7submit', function( event ) {
        grecaptcha.reset();
    }, false );

    For Contact form 7

    Is there any update on the subject?

    The same problem, disabled the plugin while others are waiting for when the author will fix the problem. Thank you.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Contact Form 7 Error Message Everytime’ is closed to new replies.