Support » Plugin: Contact Form 7 » Contact Form 7 down since WP 5.2 update!

Viewing 9 replies - 1 through 9 (of 9 total)
  • This is what puts me off updating to the latest wordpress version, forms never work after!! Our forms are what generates our revenue and they never work after an update! Arghhhhh

    The problem is API endpoint returns 404:
    /wp-json/contact-form-7/v1/contact-forms/62/feedback/ 404 (Not Found)

    I don’t know if there’s a problem with CF7 and WP 5.2, but can you try going to Settings > Permalinks and saving your permalinks. This should flush permalinks, and sometimes it fixes certain 404 errors.

    @projectarmy.
    I tried you trick but no way.
    If I look one of my other website with /wp-json directory, it’s the same answer:
    http://www.pasbanal.com/wp-json/contact-form-7/v1/contact-forms/62/feedback/
    status: 404
    But here, Contact Form 7 is working well (WP 5.1)

    @tonkascat
    I had deactivate WP auto update in wp-config.php because I watch often.

    @larudakote

    The worth: no alert message! Just a rotating arrow icon…

    The spinning arrow is a common sign of a JavaScript conflict with your WP theme or one of the other plugins you are using.

    Switch temporarily (nothing will be lost when you switch back) to a WP default theme & disable all plugins other than Contact Form 7 to see if the problem goes away.

    If it does you can switch back to your theme & re-activate each plugin one by one to see when the problem occurs.

    @buzztone
    Already done: see my first message… but no success.

    I repeat: only these two websites down, under WP 5.2 and Customizr theme. Exactly since the update the 22 of May.
    It’s a disaster! I must move twenty forms from CF7 to another plugin.

    When I check with the new WP 5.2 health test, I see one critical issue:
    “cURL error 28: Operation timed out after 10003 milliseconds with 0 bytes received”

    Note: these two websites are owned by a non profit organization I work for, since 2003.

    I tried 5.2 WP update with another website owned by a friend, no issue with CF7…

    • This reply was modified 5 months, 3 weeks ago by larudakote.

    Have you tried enabling WordPress debugging to see if any errors show up?

    You can add the following code to your wp-config.php file, you’ll see this in your file:
    define( 'WP_DEBUG', false );

    Delete that, and paste this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );

    After this is saved, try submitting form to trigger any errors. You should have debug.log with errors/warnings inside your wp-content directory.

    Let us know if there are any errors in that log file.

    @supporthero
    I already tried the debug mode and I did not found any relevant bug…
    I’m waiting for a new Customizr update, regarding the specific issue between CF7 and this template.

    larudakote

    (@larudakote)

    Hi world!

    I finally found something fishy!
    A recent test rule into my two .htaccess file to force the trailing slash.

    RewriteCond %{REQUEST_URI} /+[^\.]+$
    RewriteRule ^(.+[^/])$ %{REQUEST_URI}/ [R=301,L]

    What is really strange: not all form was impacted by this rule…

    Latest version of CF7 can not be activated in WordPress 5.2.2 – it crashes WordPress completely. WordPress isn’t even offering CF7 as compatible plugins in the search feature. Any new WordPress installs can not use CF7 – it installs but will not activate.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.