WordPress.org

Support

Support » Plugins and Hacks » Contact Form 7 » Contact Form 7 : Disable or Correct Chrome AutoComplete

Contact Form 7 : Disable or Correct Chrome AutoComplete

  • When a user selects AutoComplete, Chrome seems to fill fields at random. I’ve tried different field naming conventions, but no luck. I’d like the form to autocomplete properly, but if not, I’d like to at least shut off autocomplete. I haven’t fond a way to do either.

    Any autocomplete=”off” attributes are apparently placed in the <form> or <input> tags, but how is this added with Contact Form 7?

    http://wordpress.org/extend/plugins/contact-form-7/

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’d also like to know this.

    It’s increasingly more important for mobile sites to be able to turn off autocorrect, or automatic capitalization on certain fields.

    Is there a hook or something we can do in functions.php? I don’t really want to hack the plugin, but if that’s the only way…

    Has anyone found a solution to this?
    Thanks.

    No, never did find a way to disable the autocomplete in CF7. Ended up paying for a Gravity Forms license, works great.

    @mrcharcoal Thanks for the suggestion and quick response. Might be time for me to go “paid” as well.

    I had similar problem with autocomplete messing up my form and putting everywhere e-mail. The problem was with labels. And to be more precise, the lack of them. Every field must have a label with ‘for’ tag. Here is an example code how it should look like.

    <p><label for="your-email">Your Email (required)<label><br />
        [email* your-email] </p>
    
    <p><label for="your-subject">Subject<label><br />
        [text your-subject] </p>

    Thank you Łukasz Wilk, works for me!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Contact Form 7 : Disable or Correct Chrome AutoComplete’ is closed to new replies.
Skip to toolbar