Support » Plugin: Contact Form 7 » Contact Form 7: Can't Load it on my site?

  • I am having problems installing Contact Form 7. It just won’t load. That’s via the dashboard installer.
    I get the error message:
    Could not copy file. /public_html/wp-content/plugins/contact-form-7/languages/wpcf7.pot
    Earlier attempts said it couldn’t create the directory public_html? I tried making every folder I could think of: 777. It still didn’t work.

    If I manually upload it into the plugin folder it still doesn’t show up on my plugins page list. Yet, when I try to reupload via the dashbord, the new error message is that: Contact Form 7 already exists in the plugin folder.
    I’ve attempted to load it on several test sites and via several browsers. Any ideas would be greatly appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Same problem here … anybody can help us?

    Hi guys,

    I was having this same issue with Contact Form 7 and other plugins using the dashboard. It seems the problem is due to the owner the system assigns to the files “nobody” in my case. I’m using a CentOS+CPanel server.

    I erased them and upload them using FTP and they are working just fine in the dashboard now.

    ric_fin … did you try manually too?

    fredix … is that environment staging or production? so you can install fresh?

    Thanks Joe

    When you say you erased them I assume you mean you deleted the files. Is that correct?
    I am using CPanel. Can you help me to understand what it means to “assign the files to nobody?” and can I change that via cpanel?
    btw, My hosting company tek support guy said something about setting public_html permissions to 770. Is that what he was referring to? Is that what you are reccommending?
    again, many thanks.

    Solved… i was uploading manually and set the folder file permissions to 777.


    In UNIX based systems every file is assigned to specific owner and group.

    I don’t think you have enough visibility through your FTP client, that’s something you will need SSH access to change.

    What it seems to me is that the configuration of our Apaches doesn’t force our cpanel users to be used as both owner and group of the files the PHP is creating (the plugin files), so “nobody” user is reported.

    But later on, when the PHP tries to do something else, it does use the correct user.

    What seems to be very weird is the fact that I recursively changed all the plugin files owner and group to “arqui” (my cpanel user), and didn’t work … I tried to recursively assign 777 permissions to the files … and didn’t work either.

    Tha1ded to give the issue one more try. So,

    1. I deleted (thanks for the correction, I’m still working on my english) all the contact form 7 files (including the folder)
    2. I re-uploaded the files using FTP
    3. I enabled the module in the dashboard

    What I don’t remember is which folders and files permissions outside the plugin folder I changed last week. And I guess you don’t remember what changes you made either.

    So, I was wondering if you currently have your site in production, or you can whipe it off and start from scratch?

    Which folder did you set to 777? public_html or wp_content or – plugins?

    i am setting my wp content and plugins to 777, my public html: 750

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Contact Form 7: Can't Load it on my site?’ is closed to new replies.