Support » Plugin: Contact Form 7 » Contact form 7 appears to have broken down on me

  • Resolved Melpomene


    This isn’t easy for me to explain, but I’ll do my best.

    I was developing a new site on a sub domain using a new theme (couldn’t be certain I’d make it work or I’d like the finished product so it made sense). In the end I did like what I got and wanted to transfer the new product to my two existing domains. FTP is beyond my skills, so my host set up something they called a ‘mirror’ site (I suspect it could be their word for a clone). I was running contact 7 with few problems until about 3 weeks ago when I noticed that no one was contacting me

    A cursory look suggests that for some reason the page id that appears in the URL is now one number higher than that which appears in the back end in the plug in manager on the WP control panel. The upshot is that the contact form isn’t working, and something appears to have altered the number (or is it called a permalink?). This alteration isn’t random though, on each form its been set one digit away from that which it should be

    As you might imagine, this is pretty terminal to an online business. I’ve got to suspect it owes something to the duplicating of the site but either contact 7 doesn’t appear to be able to handle it. Is their a solution. Having coded Contact 7 in the first place, I’d prefer to continue using it, but my instinct at the moment is that I need a new contact form plug in that can cope with this

Viewing 9 replies - 1 through 9 (of 9 total)
  • what happens when you try to send an email from the contact form?

    Same thing. No joy.

    I can only really describe it as a ‘dead button’; it’s unresponsive. The lightbox works on the mouseover, but there’s no life in it otherwise

    What I have noticed since, actually let me explain

    I have 3 contacts forms. 2 of them support a specific product, the other one is a general contact form that is pretty much a catch all type of enquiry and is presented as it comes unpacked. The general form seems to be working which would indicate the pathway is clear, even if it too is displaying a different page id in the URL to that in the backend contact form administration stuff

    It would seem to indicate that perhaps there is something in the way that the coding has been laid out in the other two that is now preventing the send? However, the code is a copy and paste of something that previously worked.

    My inclination is to rebuild it step by step and see where it broke down. I’ve had the odd issue with C7 before though and have it under review as my form of choice, but it does seemingly do what I want it to (for such time as it remains operational).

    I’ve got to think that this cloning has caused it though

    This is most likely a .htaccess issue. If FTP is beyond you .htaccess is likely to be the same.

    Please include a link to your Contact Form 7 form. If others here are able to understand your actual problem, they may be able and willing to offer a possible solution.

    what does firebug or some other console say as far as errors on that page? before and after you’ve clicked the button?

    I’ve just found the cause I believe having rebuilt the whole thing from scratch and sent everything through bit by bit waiting for it to break

    It appears that the ‘acceptance of the terms’ is the culprit. Haven’t quite nailed it yet, but that seems to be the problem

    Sadly though it never gave an error message to suggest this was the issue. The button just became unresponsive.

    It seems to depend on having the default acceptance on, or inverted. I haven’t quite established which setting is working yet, but should work that out soon

    Same problem here,

    Stopped working all of a sudden

    No errors, just says ‘Failed…’
    I have tried creating a new form from scratch but no good.
    I have tried the default form that comes with it and that works.

    If it was the ‘acceptance of the terms’ I would have thought the default form would not be working either

    Right, it was the ‘acceptance’ if it helps anyone else

    It transpires that if its set at inverted the submit button becomes unresponsive but no message alerts you to this being the cause

    If you set it at check default it works

    All I can suggest you try doing Yakos is another rebuild and submit a form each time you complete a field. I know I failed once when I had stuff set up as a mandatory field and it never alerted me again. It simply stopped sending. It’s a slow process but it means putting it all back together bit by bit. In my case I had text boxes for people’s names up to a total of 12. I filled forms in using 4, but because another appeared in box 5 onwards it went unresponsive but never told me why

    I have fixed my issue.
    It had to do with ‘sending emails via SMTP’
    I have changed the way cf7 is sending emails.
    I am Using the PHP mail() function to send emails.

    If you don’t know how to do that, install a plugin called WP-Mail-SMTP
    This provides the option of sending emails via SMTP or native PHP mail() function.
    I have also found this plugin to help me in the past.

    Hope the above helps you guys

    resolved all round then by the sounds of it

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Contact form 7 appears to have broken down on me’ is closed to new replies.