Support » Plugin: WebP Express » Console errors

  • Resolved Joshaw

    (@joshaw)


    Hello,

    I installed this plugin and found the settings page shows nothing, presumably because of the console errors it throws:

    Uncaught TypeError: Cannot read property ‘length’ of undefined
    at addMissingConvertersAndOptions (converters.js?ver=0.7.0-dev24:16)
    at HTMLDocument.<anonymous> (converters.js?ver=0.7.0-dev24:202)
    whitelist.js?ver=0.7.0-dev15:2

    Uncaught TypeError: Cannot set property ‘value’ of null
    at updateWhitelistInputValue (whitelist.js?ver=0.7.0-dev15:2)
    at HTMLDocument.<anonymous> (whitelist.js?ver=0.7.0-dev15:196)
    page.js?ver=0.7.0-dev5:3

    Uncaught TypeError: Cannot read property ‘value’ of null
    at updateCacheControlCustomVisibility (page.js?ver=0.7.0-dev5:3)
    at HTMLDocument.<anonymous> (page.js?ver=0.7.0-dev5:45)
    options-general.php?page=webp_express_settings_page:1

    Failed to load resource: the server responded with a status of 500 (Internal Server Error): options-general.php?page=webp_express_settings_page:1

    The site is running on an NGINX server running Apache.
    I have tried deactivating all plugins – no change.
    I have tried using Twenty Seventeen – no change.

    Any help would be greatly appreciated.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author rosell.dk

    (@roselldk)

    Hi Joshaw,

    First, try uninstalling the plugin and installing it again.

    What do you mean with Nginx server running apache?
    Is it the “Apache behind Nginx” configuration described here: http://kbeezie.com/apache-with-nginx/ ?

    Ill off for weekend, but can look further into it next week

    Hi, any news on this issue? We run into exactly the same errors on the production environment of a website (the plugin works fine in a Docker container that we use for development).

    Plugin Author rosell.dk

    (@roselldk)

    I have just released 0.8.0. Is it also a problem in 0.8.0 ?

    We are now running 0.8.1, and the problem persists.

    Hi Roselldk,

    I’m sorry for taking so long to reply, I must have missed the email notification I received.
    I’m not entirely sure how the server is set up, I just ran it through builtwith but will get more detail for you if your update hasn’t solved the issue. I’ll try it out tomorrow.

    Thanks,

    Jo

    Having the same issue on WP 5.0.2.
    I have sites on the same server using 4.9.9 that are fine.

    Uncaught TypeError: Cannot read property ‘length’ of undefined
    at addMissingConvertersAndOptions (converters.js?ver=0.8.0-dev7:2)
    at HTMLDocument.<anonymous> (converters.js?ver=0.8.0-dev7:26)
    whitelist.js?ver=0.7.0-dev15:1 Uncaught TypeError: Cannot set property ‘value’ of null
    at updateWhitelistInputValue (whitelist.js?ver=0.7.0-dev15:1)
    at HTMLDocument.<anonymous> (whitelist.js?ver=0.7.0-dev15:22)
    page.js?ver=0.7.0-dev5:1 Uncaught TypeError: Cannot read property ‘value’ of null
    at updateCacheControlCustomVisibility (page.js?ver=0.7.0-dev5:1)
    at HTMLDocument.<anonymous> (page.js?ver=0.7.0-dev5:6)

    Plugin Author rosell.dk

    (@roselldk)

    Hopefully this is solved in the next release, with this fix: https://github.com/rosell-dk/webp-express/pull/121

    The next release is actually ready, but I’d like to do some more tests, and I’m reluctant releasing just before Christmas, without testing thoroughly (don’t want to spoil my Christmas handling an unforeseen bug). It’s a dilamma though, because several bugs have been fixed, and with ~300 downloads a day, it would be really nice to get the new release out

    • This reply was modified 1 year, 11 months ago by rosell.dk.
    Plugin Author rosell.dk

    (@roselldk)

    0.9.0 is now released. Hopefully there are no more console errors now!

    Hello,

    I have tested with the latest update of the plugin (0.9.1) and am still getting a blank white screen on the settings page with the following console error:

    Failed to load resource: the server responded with a status of 500 () options-general.php?page=webp_express_settings_page:1

    I have tried uninstalling the plugin and reinstalling but it didn’t resolve the issue.

    In answer to the kind of server being run, it’s using Plesk which I think is the NGINX/Apache setup, I’m not sure if that is as described in the link you shared, I’m not able to access to server config to really check it out.

    Do you have any other suggestions?

    Thanks,

    Jo

    Plugin Author rosell.dk

    (@roselldk)

    Hi Jo,

    Can you try to enable debugging in wp-config.php?
    Search for the line that says:

    define('WP_DEBUG', false);

    And change it to:

    define('WP_DEBUG', true);

    And then visit the options page, and see if there are any errors on the screen.
    If there are, please post them here!

    Plugin Author rosell.dk

    (@roselldk)

    I think we finally nailed the bug. It should be fixed in the new release (0.13.2).

    Plugin Author rosell.dk

    (@roselldk)

    marking as resolved

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Console errors’ is closed to new replies.