Support » Fixing WordPress » Console Error Menu Icon in Back office

  • Resolved goodigital

    (@goodigital)


    Hello,

    I have a strange problem with the wordpress menu.
    In Appearance, Menus, when I want to add an icon to the menu, the panel that opens is all white.
    And I have this error in the console:

    Uncaught TypeError: Cannot read property 'get' of undefined
        at i.setMenuTabPanelAriaAttributes (media-views.min.js?ver=5.3.2:1)
        at p (load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,hoverintent-js,admin-bar,svg-painter,wp-hooks,heartbeat,wp-auth-check,backbone,jquery-ui-position,thickbox,sh&load[chunk_1]=ortcode,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3.2:251)
        at f (load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,hoverintent-js,admin-bar,svg-painter,wp-hooks,heartbeat,wp-auth-check,backbone,jquery-ui-position,thickbox,sh&load[chunk_1]=ortcode,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3.2:251)
        at l (load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,hoverintent-js,admin-bar,svg-painter,wp-hooks,heartbeat,wp-auth-check,backbone,jquery-ui-position,thickbox,sh&load[chunk_1]=ortcode,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3.2:251)
        at h.Collection.n.trigger (load-scripts.php?c=0&load[chunk_0]=hoverIntent,common,hoverintent-js,admin-bar,svg-painter,wp-hooks,heartbeat,wp-auth-check,backbone,jquery-ui-position,thickbox,sh&load[chunk_1]=ortcode,wp-util,wp-backbone,media-models,wp-plupload&ver=5.3.2:251)
        at i.<computed> [as trigger] (media-views.min.js?ver=5.3.2:1)
        at i.propagate (media-views.min.js?ver=5.3.2:1)
        at i.open (media-views.min.js?ver=5.3.2:1)
        at i.<computed> [as open] (media-views.min.js?ver=5.3.2:1)
        at Object.pickIcon (admin.min.js?ver=1.0.0:1)

    I use the Oceanwp theme. I tried to go over a basic theme, the problem persists.

    Has anyone encountered this error?

    Best regards,
    Julien

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator bcworkz

    (@bcworkz)

    Did you also try deactivating all plugins when you tried a different theme? What theme was a “basic” theme that you tried? In particular, a caching or optimization plugins can sometimes cause strange errors like that.

    How are you adding icons to the menu? Is that a theme feature? The default menu UI doesn’t have a provision for icons, they are usually added via CSS.

    Be sure you are using the latest versions of your theme, WP, and plugins.

    Thread Starter goodigital

    (@goodigital)

    Hi,

    The bug was solve after an update.

    Best regards,
    Julien

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Console Error Menu Icon in Back office’ is closed to new replies.