Support » Plugin: WP-Members Membership Plugin » Console Error in [wpmem_form password]

  • Resolved michaelrieder

    (@michaelrieder)


    Hi Chad

    I made the update to version 3.2.6 and received a console error:
    [DOM] found 2 elements with non-unique .(index):1
    is #_wpnonce …
    Above the header of the [wpmem_form password] is an empty box now visible.
    The content class is wpmem_msg.

    Best Regards
    Michael

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Chad Butler

    (@cbutlerjr)

    Yes, there is an issue there – thanks for letting me know.

    There’s already a package of updates coming as 3.2.6.1, so these will be fixed in that update.

    In the meantime, you can resolve the message issue with an update to the inc/dialogs.php file. Lines 425 and 449 have the following comparison logic:

    if ( isset( $wpmem_regchk ) || '' != $wpmem_regchk ) {

    Change both to this:

    if ( isset( $wpmem_regchk ) && '' != $wpmem_regchk ) {

    That will provide an immediate fix. Alternatively, just as an FYI, rollback is possible as the 3.2.6 update involves no db changes.

    Thanks Chad

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Console Error in [wpmem_form password]’ is closed to new replies.