Support » Plugin: CF7 Google Sheets Connector » Consider prefixing your composer dependencies

  • Resolved mickaelperrin

    (@mickaelperrin)


    Hi,

    More and more wordpress plugins use composer dependencies in their source code by including a custom vendor directory.

    This leads to the situation where more and more plugins are incompatible because they use a different version of the same dependency.

    In order to “resolve” this issue, a singular solution is to prefix all composer dependencies with your vendor name.

    The following projects provide solutions to tackle this problem:

    https://github.com/humbug/php-scoper
    https://github.com/TypistTech/imposter

    So please, prefix your composer dependencies.

Viewing 1 replies (of 1 total)
  • Plugin Author westerndeal

    (@westerndeal)

    Hi @mickaelperrin,

    Thanks for the sending us the details.

    It is a known issue with the latest version we released and we have already fix it and updates would be soon out.

    Thanks
    Abdullah

Viewing 1 replies (of 1 total)
  • The topic ‘Consider prefixing your composer dependencies’ is closed to new replies.