Support » Plugin: Surbma | Divi & Gravity Forms » Consent field in mobile not working

  • Resolved borisbudeck

    (@borisbudeck)


    Hi,
    this plugin works very well and helps to solve the layout issues in forms, that DIVI left unattended. But we noticed, that using it along with Gravity Forms and having a “consent field” inside the field won’t work on Android smartphones. The checkbox of the consent field is not displayed at all and the form cannot be completed. The same form works perfectly in desktop browsers. After deactivating Surbma the consent checkbox shows up on the mobile devices, too. We had to set ajax to false for our forms.

    Probably someone has an idea what could cause this issue. The form can be found here (Surbma deactivaed): https://www.maileon.de/kontakt/

    Kind regards
    Boris

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Surbma

    (@surbma)

    Hi,

    thank you for using my plugin! I’m sorry if you experience something wrong.

    I just checked your website and the checkbox is not displayed, as you have a css for input fields, like this:

    
    input {
        -webkit-appearance: none;
    }
    

    And this is not a consent field, this is a checkbox field.

    So even if my plugin is deactivated, your checkbox is still not showing, that means there is nothing wrong with my plugin. I have tested it with my local install and the checkbox field and the consent field are both displayed without any problem.

    I also see, that you are using some kind of minification, which also can be a problem.

    I’m sure, there is no problem with the code of my plugin. You need to deactivate your minify plugin and debug the css to find the wrong code. I really hope, you can find out and fix it! If you need my help to find the problem, please contact me on my website: https://surbma.com

    • This reply was modified 1 month, 2 weeks ago by  Surbma.

    Hi

    thank you very much for your answer. I will contact you that way.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.