Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Consent banner keeps popping up

  • Resolved marketingnexuzhealth

    (@marketingnexuzhealth)


    Hi,

    On certain browsers the cookie consent banner keeps popping up on every page, even when accepted. I see the problem on Chrome but not on Edge. Multiple (but not all) users have reported the problem.

    Thomas

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 41 total)
  • Same issue here (navita.hu EN version keeps asking on every page, again and again)

    Same issue here…

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @marketingnexuzhealth, I just checked your site, it works fine for me. Did you try clearing your browser cache, or opening a private window?

    @geekayhu, same for your site. I just checked the site, after dismissing the banner it did not show up again. Can you try clearing your browser cache?

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @katfrajoe, please post your domain so we can take a look. In most cases the issue is caused by cached .js files. Clearing the cache should resolve the issue.

    As there can be many external factors with this issue (like another plugin which causes a javascript error) I need to see the domain to be able to tell you what the issue is.

    I did clear cache on the site. But it kept repeating the same problem. Disabled the plugin for now as it is a live ecommerce site and this is costing money.

    As for me, I manually applied the GitHub master mentioned in another thread, so it seems to be working.

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @katfrajoe if you have a live example where the issue occurs we can take a look. As we can’t reproduce any issues we’ll need a live example to help you further with this.

    Thread Starter marketingnexuzhealth

    (@marketingnexuzhealth)

    @rogierlankhorst The fact that this does not consistently happens is one of the main issues here. What I have seen in detail:

    1. Site has been working fine
    2. I ran the wizard (again) to update the cookies.
    3. Afterwards, on that computer the problem showed on the browser I used to run the wizard (Chrome for Win).
    4. The Edge browser on that same computer does not have the problem.
    5. The Chrome browser on another one of my computers also does not have the problem
    6. Another user also reported the problem on Chrome for Win
    7. Clearing all site related cookies resolves the problems, but this is not something I should have to ask from my users

    I have not been able to reproduce the problem on purpose, mainly because I do not have a test environment for the site. The two browsers that showed the problem were browsing the website when the wizard was run, but not sure that is related.

    So yes, this is a real problem (as confirmed by the other people in this thread, but from our side it is hardly possible to do any more debugging.

    What could be done, I think, is to check on the offending browsers when the cookie was written to in order to see if it gets updated when clicking the consent banner.

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @marketingnexuzhealth,

    Technically it seems to work at our end; the cookies are set on nexuzhealth.com/

    This means any subfolders and pages are included, and should not show the banner again, e.g.: nexuzhealth.com/nl/ or nexuzhealth.com/nl/page-url.

    I can imagine users visiting nexuzhealth.be, or forums.nexuzhealth.be and seeing two different banners, and therefore 2 different consent management tools.

    What also can happen is you go through the wizard and consent is revoked for all users, because there have been significant changes to the cookie policy. In this case, I would suggest clearing the cache after to see if this helps.

    There’s no need to ask your users to clear their cache.

    regards Aert

    Have the same issue on my website http://www.eemskrant.nl bud only notice it on Google Chrome

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @eemskrant, I see on your website a console error coming from the TCF implementation. I also see another cookie banner, which might complicate things. As this is unrelated to this thread, and a premium feature which we are not allowed to discuss here, can you contact support at https://complianz.io/support so we can help you with this issue?

    Thread Starter marketingnexuzhealth

    (@marketingnexuzhealth)

    @rogierlankhorst Most of my users don’t see the problem; but that does not mean that it is not a problem at all.

    The other domains you mention (forms. and .be) are not involved in my bug report at all. Of course I understand that these are separate and not influenced by the settings of the plugin on our main site.

    I understand that consent is revoked, and that is fine. But for a very limited set of users the re-acceptance does not get registered afterwards. The only solution we have found to resolve this for these users is to have them clear all cookies of our site. I can ask this of my coworkers, but not of all our visitors.

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @marketingnexuzhealth,

    I see both https://nexuzhealth.com/ and https://nexuzhealth.com/nl/ available, and some URL’s only on /nl/. It might be a recent change in the configuration of WPML, or an update might have switched the cookie path from /nl/ to only / (or the other way around). Meaning users who accepted before, based on their browser settings could get double cookies on different paths, which might interfere with the settings being saved.

    This is really the only thing I can think of without having access to the issue myself. If a user has an issue, and they’re willing to cooperate a bit to figure it out, please ask them to find the cookies for your URL and see if some are shown twice.

    groeten Aert

    Thread Starter marketingnexuzhealth

    (@marketingnexuzhealth)

    @aahulsebos @rogierlankhorst
    Today (yes, on Sunday) three more of my users have reported that the issue persists. All were coworkers, I can only imagine how many customers are facing these problems.

    There have been no changes at all in WPMPL or any other plug-in right before/around/after the problem first appeared. All users who have the problem report it only in Chrome, not Edge or any other browser. This may also be due to the fact that most typically only use Chrome, so there may not have been any older cookies from prior consent in Edge. The lack of prior consent (in Chrome) may also be the reason why you don’t see it.

    When they browse the site, they get the pop-up for every single page again and again; so if they revisit a page, they get the same pop-up every single time. That cannot be due to a path change and it renders the site pretty much unusable.

    I must insist that there is an issue with your recording of the consent and that no other plug-in is at fault because none were added/removed/upgraded around the time when the problem first appeared. There have also not been any changes to default paths or domains.

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @marketingnexuzhealth,

    Maybe a user who is having the problem can check what the cookies are which are currently stored for complianz (starting with either cmplz_ or complianz_).

    If you can post these values here, the value, path and expiration, and the URL which they were browsing on at that moment, we can check if there’s something in those cookies which can explain this. As the issue is for some users only, I expect it to be something in the cookie. With this info we may be able to deduce the cause.

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘Consent banner keeps popping up’ is closed to new replies.