• Resolved laucoste

    (@laucoste)


    Hi,

    My connection on desktop is OK, but it fails on mobile (chrome, private session or not).

    On mobile I get :

    “Not Found
    The requested URL /wp-login.php?loginSocial=facebook is not found on this server.”

    => I activated debug, here it is with interesting parts :

    // START OF THE LOGS

    * Hostname was NOT found in DNS cache
    * Trying 157.240.21.16…
    * Connected to graph.facebook.com (157.240.21.16) port 443 (#0)
    * successfully set certificate verify locations:

    […]

    < HTTP/1.1 400 Bad Request
    < WWW-Authenticate: OAuth “Facebook Platform” “invalid_request” “Missing redirect_uri parameter.”
    < Content-Type: application/json; charset=UTF-8
    < facebook-api-version: v3.2

    […]

    < Date: Fri, 15 Feb 2019 17:31:28 GMT
    < Connection: keep-alive
    < Content-Length: 117
    * HTTP error before end of send, stop sending
    <
    * Closing connection 0
    {“error”:{“message”:”Missing redirect_uri parameter.”,”type”:”OAuthException”,”code”:191,”fbtrace_id”:”C5xdaoBbi4n”}}

    // END OF THE LOGS

    => I use “Fixed redirect URL” and provided an URL (for login AND register)

    Would you see what could be wrong ?

    Thanks in advance,
    Regards,
    Laurent

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Laszlo

    (@laszloszalvak)

    Hi @laucoste

    Please open a support ticket at:
    https://nextendweb.com/contact-us/nextend-social-login-support/
    with the URL of the site where the problem can be seen and refer to this topic.

    Best regards,
    Laszlo.

    laucoste

    (@laucoste)

    Hi @laszloszalvak
    Thanks, I just created a new ticket, but I have no #TicketRef to follow.
    I just got a confirmation email.

    Regards,
    Laurent

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @laucoste

    I replied to your support ticket about 2 hours ago.
    Could you check if the suggested setting fixes your problem?

    laucoste

    (@laucoste)

    Thank you so much Laszlo Szalvak !
    It works !

    laucoste

    (@laucoste)

    Solution of my problem :

    1/ Create a new empty page and then select it as “OAuth redirect uri proxy page” at Nextend Social Login>Global Settings>General tab.
    In this way the Oauth flow would be handled on the specified page instead of the /wp-login.php.

    If you have a privacy policy or you as a extra information before the login, the you probably want to create another page and insert the shortcode: [nextend_social_login_register_flow] into it then select it as “Page for register flow”.

    2/ This setting will modify your redirect uri so you will need to add the new Redirect uri to each of your configured Apps. You will most likely receive a notification about this like:
    Nextend Social Login detected that your login url changed. You must update the Oauth redirect URIs in the related social applications.
    Fix Error – Oauth Redirect URI

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @laucoste

    I am glad it worked for you.

    Thanks for your feedback!

    I mark this topic as resolved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.