WordPress.org

Support

Support » Plugins and Hacks » [Resolved] connectionEntryList issue

[Resolved] connectionEntryList issue

  • Any idea why this code no longer works after upgrading to version 0.7.6.1?

    $directory_query = array();
    $directory_query['template_name'] = 'montand-img';
    // extract the last name from the post title and search the connections db for it
    $directory_query['last_name'] = substr(strrchr(trim(the_title('', '', FALSE)), ' '), 1);
    $search_result = connectionsEntryList($directory_query);
    echo $search_result;

    This now gives the error message ERROR: Template montand-img not found.

    I double checked that the template file is still available on the server.

    http://wordpress.org/extend/plugins/connections/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author shazahm1

    @shazahm1hotmailcom

    Although it should still work … template_name has been deprecated for almost two years, just use template.

    What is the path the template files are in?
    It should be: ../wp-content/connections_templates/montand-img

    Or, if you are on multi-site, in the appropriate blog.id path.

    Now, since you’re using the template_name option, make me wonder if you’re using the original templating system, for which support was removed last fall. If that is the case…

    You need at two files to be recognized as a template.
    1. meta.php
    2. template.php

    Take a look at the supplied templates to see what goes in each. FYI, this templating system is also now deprecated, so you might want to look at the new names template to see how that one is built.

    Thanks… I am using the old system. I’ll update it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] connectionEntryList issue’ is closed to new replies.