WordPress.org

Forums

Connection was reset - publish posts (13 posts)

  1. jtbw911
    Member
    Posted 2 years ago #

    I am having a reoccuring issue when attempting to publish new posts. If I cut them down to a short paragraph, they'll post; however, anything longer than that immediately shows a "connection was reset HTTP error.

    I've gone through all the other threads I've found about this and have yet to find a solution.

    This WordPress is running as a sub-directory instance on CentOS 6.2 with a MySQL back-end running on a separate host.

    There is another sub-directory instance of WordPress running on this server that does not have this issue. They are using the same MySQL server; but, different databases; and they are not expressly aware of each other.

    Any assistance or suggestions would be appreciated.

  2. WPProHelp
    Member
    Posted 2 years ago #

    Try to enable PHP error logging and see if there is something of interest and related to this in the php error log file.

    that should be a good start.

  3. jtbw911
    Member
    Posted 2 years ago #

    I have followed the suggestions noted in the following links, and a couple others, to enable PHP logging and I must be missing something; as no logs are showing up from PHP in either the file specified or over syslog to our syslog server.

    http://perishablepress.com/how-to-enable-php-error-logging-via-htaccess/

    http://www.cyberciti.biz/tips/php-howto-turn-on-error-log-file.html

    Any suggestions?

  4. WPProHelp
    Member
    Posted 2 years ago #

    Can you post the whole error code here please?

  5. jtbw911
    Member
    Posted 2 years ago #

    It's a typical Chrome error code. I have tried this from an external host (outside the LAN) as well and have also tried different browsers.

    This webpage is not available
    The connection to *.example.com was interrupted.

    Here are some suggestions:
    Reload this webpage later.
    Check your Internet connection. Restart any router, modem, or other network devices you may be using.
    Add Google Chrome as a permitted program in your firewall's or antivirus software's settings. If it is already a permitted program, try deleting it from the list of permitted programs and adding it again.

    If you use a proxy server, check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server, adjust your proxy settings: Go to the wrench menu > Settings > Show advanced settings... > Change proxy settings... > LAN Settings and deselect the "Use a proxy server for your LAN" checkbox.

    Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

  6. jtbw911
    Member
    Posted 2 years ago #

    If I shorten the post, it will post just fine. It seems like if it's more than just a couple/few sentences, I receive the error.

  7. WPProHelp
    Member
    Posted 2 years ago #

    It seems more like a PHP or mySQL related setting then. Did you try to make a backup of your website, install it locally (on Xampp or so) and see if you can reproduce the issue?

    As it seems the issue might be related to the hosting provider configuration.

  8. jtbw911
    Member
    Posted 2 years ago #

    This WordPress instance runs within our own datacenter on-site. The Apache host and the MySQL database server are separate virtualized CentOS 6.x server installations.

    The fact that another sub-directory instance of WordPress running off the same Apache host, using a separate database on the MySQL database server, doesn't have this issue baffles me. They do have a difference in plugins, which I can provide if that might help.

  9. WPProHelp
    Member
    Posted 2 years ago #

    So most probably the issue is related to the instance of MySQL. It is terminating the connection abnormally.

    Did you check the MySQL of the website and its logs, maybe you find something of interest?

  10. Richard Vencu
    Member
    Posted 2 years ago #

    In my case I had php upload size limited to 2M, by increasing it to 20M solved my problem.

    This problem also may happen when saving menus.

  11. jtbw911
    Member
    Posted 2 years ago #

    It seems to have something to do with filtered words on MySQL...words it does not allow in MySQL queries as a prevention against SQL injection. My problem is that it is WAY more sensitive than it needs to be, and, I am unable to find a way to modify or even remove that security measure. Any suggestions?

  12. Mischa Ipp
    Member
    Posted 1 year ago #

    Hi!

    So I am no good at website jargon and when searching these forums I cannot find a way to fix my problem that I understand - if there is even an answer for my problem in these forums at all. I also cannot figure out how to even create my own post to get help solving my problem, so I am hijacking this post with a new question and hoping someone can help!

    I asked my boyfriend in Australia to help me solve some problems with my website (he couldn't). Since he tried to help though, I cannot login to my site from my wifi (I am in the US). The strange part is that people in Australia can log in, but I get this when I try to get the login page:

    This webpage is not available
    The connection to littleytheatre.co was interrupted.
    Here are some suggestions:
    Reload this webpage later.
    Check your Internet connection. Restart any router, modem, or other network devices you may be using.
    Add Google Chrome as a permitted program in your firewall's or antivirus software's settings. If it is already a permitted program, try deleting it from the list of permitted programs and adding it again.
    If you use a proxy server, check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server, adjust your proxy settings: Go to Applications > System Preferences > Network > Advanced > Proxies and deselect any proxies that have been selected.
    Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

    It is not that I need to reset my password, it is that I cannot even get to the page to enter my password. Once this is solved I would also love some help in solving some other challenges I am having... Perhaps this can be moved to another thread?

    Thank you,
    Mischa

  13. WPyogi
    Forum Moderator
    Posted 1 year ago #

    You can start a new thread here:

    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    Please do :).

Topic Closed

This topic has been closed to new replies.

About this Topic