Support » Fixing WordPress » Connection to WordPress.org Refused

  • I have worked on this problem for two days with our ISP, who hosts our dedicated server. This problem affects all of our clients’ WordPress sites we are hosting on our server, as well as our own.

    The bottom line is that for some connections, but not all, WordPress.org refuses connection from our server. Example: This WordPress site <https://www.citywheelchairs.com&gt; hosted on our server reaches out to check the version of WordPress and installed plugins, and says they’re all up-to-date. But clicking on “Add Plugins” gets a “connection refused by WordPress.org.” Same problem with RSS feed. Once I get that “Connection Refused” message, an “Upload Plugin” button appears, and I can manually upload and install.

    Our ISP support has tried every test and setting, studied the PHP error logs, and we aren’t getting any errors.

    Health Check is all good until it tests the connection to WordPress:

    Communication with WordPress.org: Unable to reach WordPress.org at 198.143.164.252: cURL error 7: Failed to connect to wordpress.org port 443: Connection refused

    HTTPS status: You are accessing this website using HTTPS.

    Secure communication: Your WordPress install can communicate securely with other services.

    Scheduled events: No scheduled events have been missed.

    Background updates:
    No version control systems were detected.
    Your installation of WordPress doesn’t require FTP credentials to perform updates.
    Couldn’t retrieve a list of the checksums for WordPress 4.9.2. This could mean that connections are failing to WordPress.org.

    Now, here’s the evidence that it’s wordpress.org refusing these connections. The ISP duplicated the cURL call to Google, with success:

    root@server [~]# curl google.com
    <HTML><HEAD><meta http-equiv=”content-type” content=”text/html;charset=utf-8″>
    <TITLE>301 Moved</TITLE></HEAD><BODY>
    <H1>301 Moved</H1>
    The document has moved
    here.
    </BODY></HTML>

    Here’s the result of the identical action for WordPress.org. The same fail happens with port 80:

    root@server [~]# curl https://wordpress.org
    curl: (7) Failed to connect to wordpress.org port 443: Connection refused
    root@server [~]#

    RSS Feed:

    RSS Error: WP HTTP Error: cURL error 7: Failed to connect to wordpress.org port 80: Connection refused

    RSS Error: WP HTTP Error: cURL error 7: Failed to connect to planet.wordpress.org port 443: Connection refused

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 20 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    what do you get with

    curl -v https://downloads.wordpress.org/plugin/hello-dolly.1.6.zip > /dev/null ?

    Hi Steven, sent it off to ISP support. I’ll call them in a few minutes to check in. Thanks!

    Steven, same error:

    root@server [~]# curl -v https://downloads.wordpress.org/plugin/hello-dolly.1.6.zip > /dev/null
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 –:–:– –:–:– –:–:– 0* Trying 198.143.164.250…
    * connect to 198.143.164.250 port 443 failed: Connection refused
    * Failed to connect to downloads.wordpress.org port 443: Connection refused
    * Closing connection 0
    curl: (7) Failed to connect to downloads.wordpress.org port 443: Connection refused

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Ask your host to make sure they have the latest versions of openSSL installed.

    Steven, openSSL is not installed on the server. AutoSSL is. Could that be the problem?

    Thanks,

    Rob

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    AutoSSL installs certificates. I don’t think it’s responsible for managing what CURL is doing.

    OK, what do you suggest I do next? Is openSSL 1.1.1 required for WordPress to accept the connection?

    Thanks,

    Rob

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    This is getting into system administration and the peculiarities of your server setup. As the issue is with CURL, we’ve shown that it’s not a WordPress issue, but a server one. Contact the server admins and ask them if they’re using the latest versions of openSSL. They may also have to do more network level debugging.

    Steven,

    I don’t understand what you’re saying. Isn’t the WordPress server refusing to allow connection requests from our server? I’m no expert, but how else can you read this statement?

    curl: (7) Failed to connect to downloads.wordpress.org port 443: Connection refused

    If it is exactly as it seems to state, that the WordPress server is refusing to communicate with our server, isn’t there a way to troubleshoot this? If we knew exactly why the connection is being refused, we could, at least in theory, correct it.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    It’s not like I have access to those servers. Usually, this is because you’re using an invalid TLS connection.

    OK, here’s the SSL report for this site. See any clues?

    https://www.ssllabs.com/ssltest/analyze.html?d=citywheelchairs.com

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    That has nothing to do with how your SERVER makes outbound connections. As I said, this has nothing to do with your wordpress website or the wordpress software on your server.

    Ali Darwich

    (@tokyobiyori)

    SUPER-O EL MOPO

    Hello there! Like Steven said, this is more of a server issue, not exactly WP. What flags are you using for the connection?

    Hi tokyobiyori,

    I understand. Our server tries to communicate with the server wordpress.org is hosted on, and the WordPress server refuses that connection attempt. Isn’t that what this is saying?

    curl: (7) Failed to connect to downloads.wordpress.org port 443: Connection refused

    I have worked for hours over the course of two days with our dedicated server upper-level support team. They have run out of tests to run to try to diagnose this problem. This works perfectly:

    root@server [~]# curl google.com
    <HTML><HEAD><meta http-equiv=”content-type” content=”text/html;charset=utf-8″>
    <TITLE>301 Moved</TITLE></HEAD><BODY>
    <H1>301 Moved</H1>
    The document has moved
    here.
    </BODY></HTML>

    Here’s the result of the identical action for WordPress.org.

    root@server [~]# curl https://wordpress.org
    curl: (7) Failed to connect to wordpress.org port 443: Connection refused
    root@server [~]#

    What is the difference? To me, the difference is that google.com understands and accepts the connection, while wordpress.org refuses the connection.

    When you ask, “What flags are you using for the connection?”, I don’t understand what you’re asking.

    You mention “AutoSSL” so I’m assuming you’re using WHM/cPanel on your dedicated server. This is more of a question for them (cPanel support) at this point, but I can try and walk you through some troubleshooting real quickly…

    A. Check your Firewall rules within WHM. I don’t know what particular firewall option you’re using, but your ISP should know. Ask them to see if there’s anything in there that would be blocking connections to WordPress.
    B. Check any weird DNS settings. I don’t see why this would be a problem but doesn’t hurt to see if your DNS resolver has some really weird configuration.
    C. Update your server’s kernel and/or WHM version — a really outdated version of OpenSSL (which is not a part of WordPress at all, but rather a part of your server itself) can cause some issues like this. When you update your kernel in WHM, it should update all the packages with it, including OpenSSL. You can test if this is the problem by doing the same command that Steven provided earlier, but replace https with http. It should connect this time, but respond with a 301 response if it is a problem with your server’s OpenSSL/TLS version.

    • This reply was modified 1 year, 8 months ago by Laken Hafner.
Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Connection to WordPress.org Refused’ is closed to new replies.