Support » Plugin: Star CloudPRNT for WooCommerce » connection to printer gets lost

  • Hey!
    I need some help pls.
    I connected my HI01x/02X interface (on a TSP654 printer) connected to the beta Plugin.
    First it’s connected and the plugin find my printer. But I never was able to print something. Short while after connecting the printer to the WP site, the status in the plugin says: Connectivity: Not Connected

    Printer Information
    Name: 00:11:62:0d:cb:XX- Rename
    Poll Interval: 5
    Connectivity: Not Connected
    ASB Status Code: 23 6 0 0 0 0 0 0 0
    HTTP Status Code: 200 OK
    Last Communication: Fri 5 Feb 21 - 14:56:33
    Printer Identification
    MAC Address: 00:11:62:0D:CB:3E
    IP Address: 93.197.XX.XX
    Interface
    Client Type: Star Intelligent Interface HE01x/HE02x
    Client Version: 1.9.1
    Supported Encodings
    image/png
    image/jpeg
    application/vnd.star.raster
    application/vnd.star.line
    application/vnd.star.starprntcore
    text/plain
    application/octet-stream
    Printer Queue
    Priority	Order ID	Queued On
    1	59	14:53:18 (05/02/21)

    Is there some special configuration to set at the web inferface of the printer?
    Or some firewall setting?
    Strange is that first the printer is found and then not connected… 🙁

    Thx a lot!
    Jan

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter TheRealCookie

    (@therealcookie)

    BTW: The communication to the Star Micronics Cloud is working. So the firewall/router might me not the problem…

    Plugin Contributor lawrenceowen

    (@lawrenceowen)

    @therealcookie

    The symptoms mean that the printer could connect to your server at least once but has been blocked since then.

    We’ve seen this sometimes caused by local routers, but as you mentioned the Star Micronics Cloud connection is ok, this is almost certainly not an issue.

    Usually, this issue is caused by very aggressive caching on the web host, even though the WooCommerce plugin specifies that the CloudPRNT connection shouldn’t be cached, and also the HI0x takes some steps to avoid it. Some hosts still cache very heavily.

    In this case, it’s entirely our of our control, but if you talk with your hosting provider, and let them know the CloudPRNT URL for your site, they should be able to exclude that URL from caching.

    If that’s not possible, then if you are in the UK or EU we can offer an option to print by email instead of via the CloudPRNT plugin. In that case, you would need to contact Star directly to set-up an account on our service.

    Thread Starter TheRealCookie

    (@therealcookie)

    Thx a lot.
    The server is a rented root server, caching disabled.

    I changed some settings at the printer … actually dont what, but now the connection stays alive. But still no prints…
    And now there is no printer queue? Before the printjobs where shown there…

    Plugin Contributor lawrenceowen

    (@lawrenceowen)

    One other thing to check, sorry I completely forgot to mention before, is the polling time/interval setting on your printer (in the HI0x CloudPRNT Settings). Sometimes this is set to a very long interval, ideally it should be set to something between 1 to 10s. This determines how often the printer connects to your server to check for print jobs, so is also a very likely cause of the symptoms you described if it’s set too high.

    Since it is probably the only printer connecting to your server, it’s probably safe to set it to “1” to get the fastest printer response.

    A very high polling time can can make printing very slow too (slow enough to appear that it’s not printing at all), so is also the potential cause of the site not printing.

    Another potential cause of jobs not printing is the print trigger option, within the Star CloudPRNT for WooCommerce settings. Ideally this should be set to print when an order is assigned the “processing”, or “completed” status, as appropriate for your site. By default, WooCommerce assigns the “processing” status to new orders, but some sites have been configured to use a different status for new orders.

    Thread Starter TheRealCookie

    (@therealcookie)

    Thx Again!
    The polling is (and was) set to 5sec.

    I also tried to print directly from the order management in the WP Woocommercebackend (there is a CloudPRNT button) and also by changing the order status all the way.

    Look at the last line in the code block on my first post. THAT time there was a queue! Looked good, but printer never printed that out. Now no queue is visible…
    🙁

    Plugin Contributor lawrenceowen

    (@lawrenceowen)

    @therealcookie
    It sounds like you’ve done everything right, a polling interval of 5s is fine, and issuing a print using the CloudPRNT button would avoid any potential issues with the WooCommerce hooks that we use a s print trigger.

    So, first thing to check, is just open up the cloudprnt settings, make sure that the selected printer is correct and save the settings. On the outside chance that the target printer setting is not saved then you may see jobs not spooling (although honestly, unlikely, if you have only ever connected one printer anyway).

    Another potential cause of issues like this is file system permissions. The print job spooling code runs outside of the WordPress/WooCommerce infrastructure, but of course still is provided by the plugin, and runs on the same web server. It will create a folder in your sites wp-Content folder, named “star-cloudprnt”, it is essential that the plugin is able to create this folder and freely manages files in there. Please make sure that the user account your web server runs under (i.e. “www-data”) has full read/write access to that folder and all files/folders inside it. Usually a WordPress install already requires that the contents of wp-content are fully read/writeable by the web server, but I have had some cases where the permissions were changed causing issues very much like yours – e.g. being unable to push jobs to the queue.

    If this doesn’t seem to be the cause, then I’m out of any immediate ideas, if you are able to switch on debug mode for your WordPress site, and capture the log while issuing a print then it would help. Otherwise, if you are UK/EU based, then we can also offer that alternative method of integrating your site with CloudPRNT printers.

    Thread Starter TheRealCookie

    (@therealcookie)

    Hey Lawrence,
    thx again. I had no time last days to continue on this issue.
    I followed the “system permission” think… There wasn’t a star-cloudprnt folder. I’m afraid to say, that till now I left the username and password fields in the CloudPRNT section of the printer empty. Now I did enter a new admin account of my wordpress installation. -> I’m at home now and can’t see the printer, but it _seems_ to be, the printer is working now. (There is a goodlooking print protocoll and now there is a star-cloudprnt folder now)
    Is it right to enter a WP user login at the cloudPRNT settings?
    BR!
    Jan

    Plugin Contributor lawrenceowen

    (@lawrenceowen)

    @therealcookie
    There is no need to set any username/password in the printer CloudPRNT settings. That’s an option sometimes used by customers who develop their own CloudPRNT compatible servers.

    If there was no star-cloudprnt folder, then that is definitely the reason you were having problems. Of course, I can’t say why the folder wasn’t created in the first place, but if everything is working now then let’s hope the issue is resolved. If you do continue to have problems then we’re here to continue supporting you.

    Laurence,

    Apologies, I’ve been experiencing this same issue but my star-cloudprnt folder does exist. Also, in my frustration, I’ve now deleted the printer from within wordpress (in an attempt to get this working by adding it again) and it’s completely disappeared.

    Your support / guidance here would be appreciated please. You’re doing a great job by the way.

    Plugin Contributor lawrenceowen

    (@lawrenceowen)

    @spannn1981 If you have deleted the printer and it did not re-appear, then it sounds like something is completely blocking the printer from communicating with your site. Unfortunately there are several potential causes. the very first thing to check is that your local network is working ok and able to connect to the internet, and that your router is correctly assigning an IP address to the printer. Print a self-test page (switch it on with the feed button held) to see if the printer is being assigned an IP (it will be near the end of the test page).

    If you have am mC-Print model printer, then please check your printer firmware as a next step, this is printed on the first line of the self-test print. It is quite common for hosting companies to tighten up their https security occasionally, and you need version 3.0 to support the strongest security levels. If you need to update your printer firmware, then it is easiest to use the Star “mC-Print Utility” app from a phone or tablet.

    Finally, log in to your printers local web interface (or use the app) and double check that the CloudPRNT feature is enabled, the CloudPRNT URL setting matches the one for your site, and that the Polling time is not too high (usually between 1 and 10s is suggested for a WooCommerce integration).

    I hope this is enough to get you up and running, but let me know if you still have trouble.

    @lawrenceowen thanks for the reply. I think you’re doing a great job supporting us all by the way!!!

    I can connect to the printer locally and it also appears ‘online’ in Star Micronics Cloud. The printer is an mC-Print model and the firmware is v3.3.

    The Polling time is set to 1 in the CloudPRNT feature and the URL setting is correct.

    I have noticed that there is no folder in the wp-content directory. Could this be the issue? How do I correct it please as removing and reinstalling the plugin doesn’t appear to do anything.

    Many thanks

    @lawrenceowen further to the above. When I couldn’t get the printer to print an order I changed the Cipher Suites Encryption level to medium. Setting this back to medium + high appears to have caused the printer to reappear. I do however still have my original issue of orders not printing. The printer status is below:

    Version 2.0.2
    Printer Information
    Name: 00:11:62:1c:0d:c5 - Rename
    Poll Interval: 1
    Connectivity: Connected
    ASB Status Code: 29 a 0 0 0 0 0 0 0 0 0 0
    HTTP Status Code: 200 OK
    Last Communication: Wed 24 Mar 21 - 12:41:22
    Printer Identification
    MAC Address: 00:11:62:1C:0D:C5
    IP Address: 86.161.158.196
    Interface
    Client Type: Star mC-Print2
    Client Version: 3.3
    Supported Encodings
    application/vnd.star.starprnt
    application/vnd.star.starprntcore
    text/plain
    image/vnd.star.png
    image/png
    application/octet-stream
    Printer Queue
    No items found in printer queue.
    Printed Order History
    No printed previous orders have been logged.
    Delete Printer
    You cannot delete the printer whilst it is connected
    Plugin Contributor lawrenceowen

    (@lawrenceowen)

    @spannn1981
    Thank you for doing a lot of the ground work, I think you’ve ruled out a lot of the potential causes.

    • Firmware – this is definitely ok, I can see that you have version 3.0, and now that you have the https security configured to enable stronger security (earlier versions did not have this setting) then your server does appear to be allowing the printer to connect.
    • Your outgoing internet connection seems to be fine.
    • Web server file permissions seem to be ok, since you could now connect the printer. I assume that the folder has now been created in wp-content? If the plugin could create this folder, then it’s most likely able to create/modify/delete other folders and files within it.

    In my experience, this means that the most likely cause is traffic filtering and caching performed by your hosting company. Unfortunately many of these services (intended to speed up access to your site) will cache connections that should not be.
    Probably this caching is performed by your web hosting company, or by whoever set-up your WordPress site, please contact them and ask them to exclude your sites CloudPRNT URL from caching.
    Alternatively, you may have arranged for your site to be accessed via a third party traffic filter like cloudflare?
    Finally, much less common, but it may be that your local internet connection is via a proxy service or that your router also does some traffic filtering? This could potentially cause similar issues.

    Unfortunately, these are network issues so mostly outside of my ability to help with, other than broad advice. But I just noticed that you have contacted us directly via the contact form too, so if you like, I can give you test access to a Star hosted CloudPRNT service, which would at least let you confirm or rule out a local router/proxy issue.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘connection to printer gets lost’ is closed to new replies.