Support » Plugin: FG Drupal to WordPress » Connection refused, hosted by Pantheon

  • Resolved lisa

    (@lisathirdsideco)


    I saw a previous support topic where a user could connect to a Drupal site without needing to specify the Drupal table prefix, but I’m not able to do that. The source website is hosted on Pantheon, which does not support table prefixes. However, when I try to connect via MySQL, I keep getting a “connection refused” error.

Viewing 1 replies (of 1 total)
  • Plugin Author Kerfred

    (@kerfred)

    The prefix is optional. It can be empty.

    If you get this error: “connection refused”:
    First verify your login and password to the Drupal database.

    If Drupal and WordPress are not installed on the same host:
    If you use CPanel on the Drupal server, a solution is to allow a remote MySQL connection.
    – go into the Cpanel of the Drupal server
    – go down to Database section and click “Remote MySQL”
    There you can add an access host (WordPress host). Enter the access host as the SOME-WEBSITE-DOMAIN-OR-IP-ADDRESS and click add host.

    Another solution is to copy the Drupal database on the WordPress database:
    – export the Drupal database to a SQL file (with phpMyAdmin for example)
    – import this SQL file on the same database as WordPress
    – run the migration by using WordPress database credentials (host, user, password, database) instead of the Drupal ones in the plugin settings.

Viewing 1 replies (of 1 total)
  • The topic ‘Connection refused, hosted by Pantheon’ is closed to new replies.