Support » Plugin: Redis Object Cache » Connection parameters are ignored?

  • Hello

    first of all: great plugin, well done.

    I have problems with the connection parameters in m wp-config.php – some of the parameters are being ignored, some of them I can validate in the diagnose dialog, some not.

    These are the parameters I want to set:

    /** Redis Object Cache Plugin Settings **/
    define ('WP_REDIS_DATABASE', '1');
    define ('WP_CACHE_KEY_SALT', 'mydomainB');
    define ('WP_REDIS_SELECTIVE_FLUSH', 'true');
    define( 'WP_REDIS_IGNORED_GROUPS', [
        'counts', // keep this
        'plugins', // keep this
        'userlogins', // userlogins
    ] );

    The first one WP_REDIS_DATABASE seems to be set correct, I see in the Servers section of the plugin settings that Database is configured – but not used in fact.
    When looking at my Redis Server I see that all keys are being written to Database 0. Please note that my Redis Server can run 16 databases, i.e. the default.

    The salt is respected and set, this works.
    WP_REDIS_SELECTIVE_FLUSH isn’t listed when looking at the diagnose screen, I tried true and ‘true’ as possible values
    WP_REDIS_IGNORED_GROUPS is listed correctly, but when looking at the values underneath I see the default settings:
    Global Groups: [“blog-details”,”blog-id-cache”,”blog-lookup”,”global-posts”,”networks”,”rss”,”sites”,”site-details”,”site-lookup”,”site-options”,”site-transient”,”users”,”useremail”,”userlogins”,”usermeta”,”user_meta”,”userslugs”]
    Ignored Groups: [“counts”,”plugins”,”wordfence”,”themes”]

    What is wrong here?

    Thanks,

  • The topic ‘Connection parameters are ignored?’ is closed to new replies.