Support » Plugin: Gmail SMTP » Connection: opening to smtp.gmail.com:587, timeout=300, options=array ()

  • Resolved Dolomats0

    (@dolomats0)



    Hello.

    I m not able to send test message after istalling this pluging.

    Here is the error i get :

    Connection: opening to smtp.gmail.com:587, timeout=300, options=array ()
    Connection: Failed to connect to server. Error number 2. “Error notice: stream_socket_client(): unable to connect to smtp.gmail.com:587 (Permission denied)
    SMTP ERROR: Failed to connect to server: Permission denied (13)
    SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    The installation was fin i m connected to google API.

    Server Info :

    OS: Linux labo.dolomats.xyz 3.10.0-514.2.2.el7.x86_64 #1 SMP Tue Dec 6 23:06:41 UTC 2016 x86_64
    PHP version: 5.6.29
    WordPress version: 4.7.1
    WordPress multisite: No
    openssl: Available
    allow_url_fopen: Enabled
    stream_socket_client: Available
    fsockopen: Available
    cURL: Available
    cURL Version: 7.29.0, NSS/3.21 Basic ECC

    NB : I m on my dedicated server no postfix or any mail service are installed that s why i wanna use this plugin, dont wanna install a whole mailing server for only a contact form.

    I searched on the forums and your website troubleshooting but no way, wasen’t able to resolv that.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author naa986

    (@naa986)

    Hi, It sounds like port 587 is blocked on the server. Can you please contact your host to make sure that it’s not blocked?

    I resolved the problème.

    I Needed to install a Mail server (Postfix/Dovecot).

    I was thinking that this plugin is working without these service’s (Postfix/Dovecot)

    That’s why i wanted to use it to avoid installing a Mail server, but seems i was wrong.

    Anyway Thanks for the help.

    No, you don’t need a mail server. This connects directly to gmail.

    By the way, if you are with digitalocean and have IPv6 enabled, you need to make a small config change for this to work. Please let me know if this is the case.

    Hi,

    I have my own dedicated server that i installed from scratch CentOS 7.

    And i m not using IP V6.

    How can we determine if port 587 is blocked by our hosting provider? Just submit a ticket to ask? Or is there a programmatic way to figure it out?

    Hi,

    Go to this website -> http://www.yougetsignal.com/tools/open-ports/

    Put ur ip address and the port u wanna check and it will tell you.

    NB : if no service is running on this port it will be reported as closed.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Connection: opening to smtp.gmail.com:587, timeout=300, options=array ()’ is closed to new replies.