• Resolved codeexplorer1

    (@codeexplorer1)


    Hi,

    I am also facing the Connection failed issue. The site was working fine since last few months. Then when I checked it was showing the connection failed issue. I have discussed with the hosting provider. They told me that the port is 11211. I have also set the same Whereas the host is localhost.

    Please guide. Thanks

    Following are the settings:

    Memcached Extension: Enabled
    Redis Extension: Enabled
    Connection Test: Failed

    The report details are as follows:

    Report number: OTGUTCIM

    Report date: 08/17/2023 11:53:22

    • This topic was modified 10 months, 1 week ago by codeexplorer1.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support qtwrk

    (@qtwrk)

    <?php
        $mc = new Memcached();
        $mc->addServer('127.0.0.1', 11211);
        $mc->set('foo', 'bar');
        $value = $mc->get('foo');
        echo $value;

    if you create a php file with above code, access by browser, what does it return ?

    Thread Starter codeexplorer1

    (@codeexplorer1)

    The above code is not returning any value. It is blank.

    Following are the settings::

    • This reply was modified 10 months, 1 week ago by codeexplorer1.
    Plugin Support qtwrk

    (@qtwrk)

    then it means the Memcached is not running , please check with your provider

    Thread Starter codeexplorer1

    (@codeexplorer1)

    I have checked with them and they said it is enabled and in the wordpress settings also it is shown as enabled. I am presenting here two screenshots, one is of wordpress and another of phpinfo.php that the service provider has given. Am I doing something wrong?

    Plugin Support qtwrk

    (@qtwrk)

    you can forward them above script

    when people talk about Memcached with PHP , there are 2 parts

    the one in your phpinfo page is the extension that enables PHP to be able to connect to memcached , it’s like the middle-ware

    where the memcached server process will be bond and listenning at port 11211 to accept the connection from PHP

    so you basically have the extension enabled, but doesn’t have Memcached server process

    Thread Starter codeexplorer1

    (@codeexplorer1)

    Thank you. I will ask them to run the script.

    Thread Starter codeexplorer1

    (@codeexplorer1)

    I have asked Godaddy Technical Team. For almost an hour’s time they fail to understand what to do. Then again hey have told that since it is showing on phpinfo page it means it is running.

    I don’t know what to do. I am thinking to move my hosting to some other service provider.

    Plugin Support qtwrk

    (@qtwrk)

    you can forward them these links

    https://www.godaddy.com/help/is-memcached-working-40532

    https://www.godaddy.com/help/install-the-memcached-daemon-40463

    https://www.godaddy.com/help/how-do-i-install-memcached-on-my-linux-server-40534

    but I don’t think shared hosting plan will have Memcached daemon , a VPS plan or higher might be required.

    • This reply was modified 10 months ago by qtwrk.
    Thread Starter codeexplorer1

    (@codeexplorer1)

    You are right shared hosting doesn’t have Memcached daemon, but their backend team was also not able to check, when I have forwarded to them. They first told it will take 30 minutes, after that they will be able to telnet. After 30 minutes they said it is running fine. Then I told them that the following memcache code is not returning the desired result, they just told that they check through phpinfo page only. Anyway, thanks for your guidance and help. I have decided to change the service provider as GoDaddy team is not able to address the issue.

    <?php $mc = new Memcached(); $mc->addServer('127.0.0.1', 11211); $mc->set('foo', 'bar'); $value = $mc->get('foo'); echo $value; ?>
    
    
    Plugin Support qtwrk

    (@qtwrk)

    you could check our hosting partner list that you may find a suitable one for you 🙂

    Thread Starter codeexplorer1

    (@codeexplorer1)

    Thank you. 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Connection failed’ is closed to new replies.