Support » Plugin: Connector for WooCommerce and Zoho CRM » Connection Error

  • Resolved karys1

    (@karys1)


    Hi,

    I am trying to get the free version of the plugin to work with the intention of upgrading to the pro version when I know how it works.

    When I try to connect to my CRM I get this error:
    ‘An error occurred while attempting to connect your Zoho CRM account. Please ensure that your email/username and password is correct.’

    The username and password are correct and I’ve removed as many authtokens from the Zoho account as possible, any help would be much appreciated!

    I also get these errors in debug:
    ‘Warning: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/[domainnameremoved]/public_html/wp-content/plugins/connector-for-woocommerce-and-zoho-crm/PP_Zoho_API.class.php on line 64′

    ‘Warning: file_get_contents(https://accounts.zoho.com/apiauthtoken/nb/create): failed to open stream: no suitable wrapper could be found in /home/[domainnameremoved]/public_html/wp-content/plugins/connector-for-woocommerce-and-zoho-crm/PP_Zoho_API.class.php on line 64′

    Thanks in advance for your help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Potent Plugins

    (@hearken)

    Hi there,
    Based on the debug messages, it appears that the connection cannot be established because the “allow_url_fopen” configuration parameter is set to 0, which disables the connection method used by the plugin to connect to the Zoho CRM API. Please ask your web host if this can be changed to allow the connection to proceed. The pro version of the plugin uses cURL as an alternative to establish the connection, and this alternative will likely also be migrated to the free plugin at some point (hopefully soon), at which point this shouldn’t be an issue anymore provided that PHP cURL is enabled on the server.

    Thanks for your help. I’ll contact my webhost 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Connection Error’ is closed to new replies.