Support » Plugin: Jetpack by » Connecting WordPress to Facebook Business Page

  • Resolved shayeryan


    I have a website I have the publicize app configured in Jetpack and I’m able to get my posts to show up on Twitter no problem. When I go to add my Facebook connection it give me an error saying

    “You are using Facebook as Sky Art Media
    To access this page, you’ll need to switch from using Facebook as your page to using Facebook as yourself.”

    I can switch to my personal profile and get this connection to work.

    I don’t want to share posts on my personal profile, I want to share them on my business page. I know this is possible because I have another website that is doing it successfully.

    Any ideas would be much appreciated!


Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    You should indeed be able to connect to a Facebook Business Page from the sharing settings, when logged in to Facebook as yourself, but we currently experience issues with the Publicize function. We’re working on it, and will release an update to fix this issue very soon.

    You can read more about it here:

    Oh great, thanks for letting me know, I was starting to go crazy.

    I was able to get another site connected to a business page which is weird. If it would help in your debugging I would be happy to set you up with a login to see the site where I am publicizing to.


    I have been experiencing the same problem as well. Look forward to this fix!

    The same overhere! Please make an update for the whole plugin so also not-experienced users can use it without problems!

    I’m not sure if this is the same issue that you guys are having, not being able to select your Facebook page for publicizing, but there is a patch for that while they work to resolve the issue that should get you back up and running with your Facebook pages.

    I’ve used it on several of our sites and it does restore FB Page functionality.

    Just upload and replace your publicize.jetpack.php file (save a copy first, just in case) in the /wp-content/plugins/jetpack/modules directory.

    Hope it helps!

    ooops…./wp-content/plugins/jetpack/modules/publicize directory. Sorry about that.

    Just tried this and still getting the same error, trying to use my personal profile. Isn’t there a way to roll back the plugin to release where this was working?

    Could the issue be that this plugin is already attached from another website to one of my other business pages.

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    @shayeryan If you experience issues when trying to connect to your personal profile, then your problem is different from the one I mentioned earlier.

    Do you still get the same error message you mentioned in your first post? If so, could you go to Facebook, and switch to your personal account thanks to the dropdown menu in the top right corner?

    Jeremy, the only thing I want to do is send posts to my Facebook business page, not my personal page. I have a design website and blog and want to connect it to Facebook. Still the same issue.

    You were probably confused by this “Just tried this and still getting the same error, trying to use my personal profile” What I meant is is still trying to force me to use my personal FB profile.

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    You were probably confused by this “Just tried this and still getting the same error, trying to use my personal profile”

    I was, indeed. I understand now, thanks!

    The fix mentioned by @waylaydesign seems to work for most people. We’re still testing it though, and plan on releasing a new version of Jetpack as soon as we’re happy with all our tests.

    If it doesn’t work for you, I’m interested! Could you make sure that your Jetpack plugin includes the changes mentioned here?

    Hey Jeremy,

    I went to that page and downloaded the zip archive at the bottom that contains the jetpack PHP file and uploaded it to said directory after renaming my original for backup. I’ve tried connecting my business page several times and still getting the same issue. I’ve logged out of WP and back in and still getting same.

    If there is anymore info I can provide that will assist in debugging I would happy to.


    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    @shayeryan Could you try to delete the existing Jetpack plugin files, and install the latest Beta version instead?

    Let me know how it goes.

    It’s working my friend, brilliant!

    I’m able to connect my Facebook Business page. I will test actually posting and publicizing next.

    Thank you!

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    We’ve just released a new version of Jetpack, 2.3.2, including a fix for this problem.

    You can go ahead and update the plugin as soon as you get a notification in your dashboard!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Connecting WordPress to Facebook Business Page’ is closed to new replies.