Support » Plugin: WP-Piwik » Connecting my blog to piwik

  • Yesterday i reinstalled my piwik installation. Since then i can’t connect from wordpress to the new installation.

    I setup your plugin new (deactivate and activate it). Fill in the URL to Piwik (which has an HTTPS connection) and the API-Key.

    i ran the test script and it fails. But if i copy and paste the URL with the token in my browser, i get the correct xml output. I allready tried it with http (without ssl) but the same effect: no connection to my installation.

    Additionally is similar if i try via https://domain/piwik or /var/www/domain/piwik.

    Do you have any infos or tips that i can try?

    http://wordpress.org/extend/plugins/wp-piwik/

Viewing 2 replies - 1 through 2 (of 2 total)
  • I have a similar problem. The Piwik plugin still tells me, that there is a connection error for the last few days now.

    I was somehow irritated, when I opened up my piwik installation a few days ago to see, that obviously the number of visitors in the overall count had decreased, when it should increase until the end of the month. Maybe this has something to do with it? Maybe it is something totally different?

    Plugin Author braekling

    (@braekling)

    neunzehn82: If WP-Piwik and its test script fail, but opening the URL manually works fine, this looks like some restriction issue.

    – Try to configure an user agent.
    – Check if you are using a “anti spam htaccess configuration”.
    – Does your Piwik URL fit the trusted domain configured in Piwik?

    if_Patrick: Can you try to disable the cache functionality and try again, please? (see Settings -> Tracking)

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Connecting my blog to piwik’ is closed to new replies.