WordPress.org

Support

Support » Plugins and Hacks » Connecting Jetpack to WordPress.com error

Connecting Jetpack to WordPress.com error

  • I just recently moved my site to self hosting, and was able to set up jetpack perfectly. However I found out that the server I was using wasn’t able to handle the load we needed, so I just transferred to another server (2 servers in 1 week, its crazy.)

    Everything seems to be working just fine on the new server now (Hostgator), but for some reason I get the following error when I try to connect JetPack to WordPress.com

    *********
    Invalid request, please go back and try again.
    Error Code: invalid_request
    Error Message: Mismatch in redirect_uri.
    *********

    Does anyone know what might be happening? How to fix it?

    Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m also having the same problem after I changed the WordPress address and ite address of my site.

    I had the same thing and just figured it.

    Let me know if this works for you:

    1. Go to PLUGINS and De-Activate Jetpack.

    2. Then DELETE Jetpack.

    3. Download a fresh install of Jetpack here: http://jetpack.me/

    3. Then go to ADD PLUGINS and navigate to the ZIP file that you’ve just downloaded.

    4. Once installed, activate it and you should be able to complete the process.

    Good luck!

    Great, it worked! Thanks!

    I was able to add the Jetpack Plungin, per your instructions…thanks for that, but now I can’t get rid of the connect to WordPress.com to get all your features message. Perhaps I missed it among all the other things that I am trying to learn. So, how do I get rid of the message?

    Thanks @mich1s, that worked perfectly.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Connecting Jetpack to WordPress.com error’ is closed to new replies.
Skip to toolbar