Support » Plugin: Wordfence Security - Firewall, Malware Scan, and Login Security » Connecting back to this site via IPv6

  • Resolved Amino Studio

    (@aminogfx)


    Hello, I have several servers and the error {wp_remote_post() test back to this server failed! Response was: cURL error 7} only happens on a single server with more than 10 sites.
    I configured everything well on Cloudflare by adding the IPs used by WF, in addition to 3 Wordfence Central IPs and also on the WF firewall whitelist. Nothing works !
    I send you the report.
    Thanks 🙂

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support wfpeter

    (@wfpeter)

    Hi @aminogfx, thanks for sending your diagnostics over!

    Whilst cURL Error 7 usually means that the website can’t make the connection to our servers at all, Cloudflare assigns an IPv6 address to your site even if your host doesn’t give you an IPv6 address. As you’re on Cloudflare, this is the likely cause for a connection failure to be reported here.

    It could be beneficial for you to check “Use only IPv4 to start scans“, which can be found in Wordfence > All Options > Scan Options > Advanced Scan Options as I see the v4 connection check is working fine.

    If the scan and plugin updates work under these conditions, the error in the diagnostics page can be disregarded. I would ask you to ensure that you’ve also added your site’s IP to the Cloudflare Whitelist in addition to ours as this can be a common problem, but the IPv4 connection in your diagnostics seems to be communicating OK already.

    Thanks,

    Peter.

    Thread Starter Amino Studio

    (@aminogfx)

    Thank you very much, Peter! In fact, I have no problem scanning and everything works perfectly fine… The only concern is that the IPv6 connection works perfectly on a VPS under Debian and that on another almost identical server, it doesn’t work.
    I will mark the ticket as solved and I wish you a good continuation. You do a great job!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.