Support » Plugin: WooCommerce Payments » Connected Wrong Stripe Acct to Woo Payments – Logout, Purge Cache Not Helping

  • Resolved Jared

    (@jstecklercfanyorg)


    Hi Guys,

    I intended to test out WooCommerce Payments on my client’s DEV site — instead, I accidentally connected my test Stripe account to his PRODUCTION site. I’ve tried signing out to allow my client to create/connect his own Stripe account, but no matter what I try, I remain signed in.

    Following along with the related documentation, I’ve attempted to purge the cache via the WooCommerce > Status > Tools page as well. Still nothing. I’ve disabed and deleted the WooCommerce Payments plugin (before reinstalling to check if that helped), cleared the Cloudflare cache, cleared the Avada Theme cache — all of it to no avail. No matter what I do, I’m stuck logged in and connected to WooCommerce Payments via the jsteckler1@gmail.com Stripe account.

    Is there anyway to erase *all* WooCommerce Payments plugin settings so that the account ‘Getting Started’ process works like a fresh install again, and allows my client to create and connect his own Stripe account?

    I sincerely appreciate the help.

    – Jared

    The site I need help with is comfyhearth.com.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support kellymetal a11n

    (@kellymetal)

    Hi there Jared,

    If there is an existing connection to WordPress.com via Jetpack, then that connection will be used to connect WooCommerce Payments as well. It appears the comfyhearth.com site is currently connected, so please try the following:

    – Disconnect Jetpack
    – Deactivate and Delete the WooCommerce Payments plugin
    – In an incognito/private browser window (to ensure there are no WP.com/WooCommerce.com account logins active), log into the comfyhearth.com site, and reinstall WooCommerce Payments
    – It should then prompt you to go through the setup/connection steps
    – Once WooCommerce Payments is connected, reconnect Jetpack

    Please let me know how that goes, or if you have any questions!

    Thread Starter Jared

    (@jstecklercfanyorg)

    You are a godsend, my friend. Thank you sincerely for the thoughtful response — and the only solution to both work and clearly demonstrate an understanding of the circumstances I laid out. The more formal Jetpack and WooCommerce support channels were not nearly as helpful, and I truly appreciate that fact!

    Thread Starter Jared

    (@jstecklercfanyorg)

    Shoot — I’m sorry — I spoke to soon.

    Following your steps did result in the setup/connection prompt, but only as far as connecting the site to WordPress.com via Jetpack goes. Once I was reconnected, the account was already (or still) linked to the same Stripe account.

    Again I tried clearing the Payments cache via Status > Tools. I performed all of the reconnecting steps not only in a private browser window, but in a totally different browser’s private window. And on top of that, I even created a brand new WordPress.com account for the connection. Despite all of that, I’m still connected to the same Stripe account. Sheesh!

    Plugin Support Shohan Hossain Nabil – a11n

    (@sohanhossain)

    Hello @jstecklercfanyorg,

    I am sorry to hear that. Please contact us at WooCommerce.com > My Account > Support. You may need to create an account before you can access that page.

    Please include a link to this forum thread, so that we can keep track of what’s already been done.

    We will be able to help you further there.

    Thanks!

    Plugin Support Augustus – a11n

    (@augustuswp)

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – If you contacted us via WooCommerce.com, we will get back to you via email!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Connected Wrong Stripe Acct to Woo Payments – Logout, Purge Cache Not Helping’ is closed to new replies.