Support » Plugin: Jetpack by WordPress.com » Connected to WP.com account, but many issues

  • Resolved mikehermary

    (@mikehermary)


    Hello,

    We have created a WP.com account and have connected it to JetPack on our website, but JP keeps displaying this message “Jetpack is powering your site, but to access all of its features you’ll need to create an account.”. When I click the “Create Account” button, the page is refreshed and the following error is displayed:

    Error Details: The Jetpack server could not communicate with your site’s XML-RPC URL. If you have the W3 Total Cache plugin installed, deactivate W3 Total Cache, try to Connect to WordPress.com again, reactivate W3 Total Cache, then clear W3 Total Cache’s cache.

    When I visit https://www.todayville.com/xmlrpc.php, the following message is displayed:

    XML-RPC server accepts POST requests only.

    I have run this terminal command:

    curl -A ‘Jetpack by WordPress.com’ -d ‘<methodCall><methodName>demo.sayHello</methodName></methodCall>’ https://www.todayville.com/xmlrpc.php

    and this is what is returned:

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <methodResponse>
    <params>
    <param>
    <value>
    <string>Hello!</string>
    </value>
    </param>
    </params>
    </methodResponse>

    When I click on the “Configure your notification settings” link, I am directed to our WP.com account page (https://wordpress.com/settings/security/www.todayville.com), but nothing related to the account loads. It just states that I have no WordPress sites yet.

    The site is using WP Network and has three sites currently setup.

    Any ideas on why we are having such issues?

    Cheers,

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    Error Details: The Jetpack server could not communicate with your site’s XML-RPC URL.

    Jetpack is being blocked from connecting to your site, but you are right, there are no obvious blocks when visiting or cURLing the file directly. The tests from our end are blocked though, so something is specifically targeting the connection method.

    If you are using any security plugins, please try connecting with those temporarily deactivated. If you don’t have any, or if that didn’t work, I would suggest contacting your hosting provider and asking them to unblock your site’s XML-RPC. The most popular hosting providers out there have managed to find other ways to protect their servers without having to hinder your site and your ability to use services with your WordPress.

    When I click on the “Configure your notification settings” link, nothing related to the account loads. It just states that I have no WordPress sites yet.

    That just means you aren’t logged into WordPress.com as the connected WordPress.com account.

    You can see what that account is, or reconnect to a different WordPress.com account, at Jetpack > Dashboard > Site Connection > Manage Site Connection in your site’s Dashboard.

    mikehermary

    (@mikehermary)

    Hello,

    We were able to solve the issue by disconnecting, then reconnecting Jetpack with WordPress.com.

    Cheers,

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.