Support » Localhost Installs » connect to remote mysql

  • hi. i have two servers 1: a vps 2 a shared. i want to create a db for wordpress in my site a for my site b, but couldnt make it connect. Then i go to wamp localhost and input the details of my remote db and it works, so its a thing with my shared hosted. but idont knwoe wthat to do at this point. can you help me please?

    shaed using cpanel. i added the ip of server 1. into the remote mysql. what to do next? thanks in advance

Viewing 3 replies - 1 through 3 (of 3 total)
  • After enabling mysql on external connection you have to create the database and the user.
    https://dev.mysql.com/doc/refman/5.7/en/account-names.html
    From phpmyadmin the HOST field set to ANY_HOST enables remote IP, obviously before you have to unlock the mysql file.
    https://dev.mysql.com/doc/refman/5.7/en/problems-connecting.html

    If the server was started with the skip_networking system variable enabled, it will not accept TCP/IP connections at all. If the server was started with the bind_address system variable set to 127.0.0.1, it will listen for TCP/IP connections only locally on the loopback interface and will not accept remote connections.

    Since you can connect to the remove database on your localhost setup, that means it’s correctly set up for remote access. Make sure to check the mysqli.default_port setting in php.iniand verify it matches the port you’re using for remote MySQL. You should also check with your host to insure they aren’t blocking that port.

    thanks to booth.

    Duio. the php.ini you mean on the server b? i cant check the php.ini just edit some vbasic stuff. and on my server 1 its right set to port. 3306 i dont want to contact my support unless its very necessary.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.