Support » Plugin: Add Polylang support for Customizer » Confusing UX with Customizer Autosave

  • Resolved Benjamin Pick

    (@benjaminpick)


    Thank you for this wonderful plugin. It works, however:
    I managed to copy texts from one language to another without realising it!

    The bug can be reproduced as follows:
    – In my case, the primary language is EN, the translated language DE.
    – In the customizer, Go to DE, change something (e.g. site title), DO NOT publish
    – Change language to EN, confirm “Yes I want to leave the page” (e.g. because I want to discard the changes)
    – When EN is loading, it says, “I have found an autosave, do you want to restore it?” Click on restore
    – Then the changes that I did in DE now appear in EN.

    IMO this behavior is confusing. I would have expected the changes from DE to stay as autosave in DE, or to be discarded silently. The easiest workaround is to not use Autosave, is there a way to disable this feature?

    Wordpress Version: 6.0.2
    Plugins used:
    Add Polylang support for Customizer Version 1.4.4
    OnePress Plus Version 2.3.3 by famethemes
    Polylang Version 3.2.6 by WP SYNTEX

Viewing 1 replies (of 1 total)
  • Plugin Author richardevcom

    (@richardevcom)

    Hi there.

    Thank you for kind words and sorry for late reply. Finally I have time to reply. 🙂

    You are right, that does sound confusing. This also could explain another support question previously, regarding dublications in different language. I think you have something here. Thank you for reporting it. I will look into it next weekend.

    Regards,
    Richard

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.