Support » Fixing WordPress » confused about settings – readings

  • Resolved RobertPavlis


    I have 2 menus; Bog and About. I want the Blog to be the main page and have posts going to it.

    In Settings – Reading. I would expect to select the “Front Page displays your latest posts”. But when I select this posts are not displayed under the Blog menu.

    If I select statis page, and post page = blog it works.

    but that seems wrong based on my understanding of the setting.

Viewing 8 replies - 1 through 8 (of 8 total)
  • which version of wordpress you are using

    I think that you probably have a page called Blog? If that’s the case, then yes, selecting front page displays your latest posts won’t work.

    What you could do is in your Menus settings, delete the menu item call Blog and then just create a custom item and insert your home page url and call that one Blog. You can also delete the page blog, since you don’t need it.

    If you don’t use a custom menu, normally themes display a home menu item. You can change that to say Blog, but that will depend on your theme.

    Current version of WP – just installed today.

    I do have a page called Blog.

    What is a ‘custom item’?

    Christine – if I follow your advice I still end up with a page called blog. I don’t undersstand the issue. Is the problem that WP can’t use a URL other than

    Are you using a custom menu?
    What happens when
    1. you have one page – About
    2. Set your home page to display blog posts
    3. Do not have a custom menu.

    You’re home page should now by the blog, but will not necessarily say blog on the navigation bar. And you should have a page called about.

    Please provide a link to your site, so we can see what’s going on.

    I removed the blog page. I have selected Front Page displays your latest posts and when I go to URL the posts show up.

    but now I don’t see any way to add a menu item with the URL

    the theme did have a Home menu item which I deleated. The deleted pages seem to be saved, but I don’t see a way to get it back?

    Ok, now go to Appearance and create a new menu.

    Do you see the box that says Custom Links in the left?
    Had your and then type Blog in the label.
    Add that to the Menu

    Then select your page called about and add it to your men.

    That should give you what you want.

    That worked. It is completely illogical, but it did work.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘confused about settings – readings’ is closed to new replies.