Ready to get started?Download WordPress


Confused (8 posts)

  1. Stephen47
    Posted 9 years ago #

    OK - I can't get it installed. I keep getting a error that says: Error establishing a database connection - I have the right database, username and such down, so what am I doing wrong? Thanks.

  2. gnukerman
    Posted 9 years ago #

    I have had the problem in the past and found it was the format of the database password. i.e. too many characters, invalid characters, etc...

    Try a shorter password if your current one is more than 14 characters.

    Hope this helps.

  3. Stephen47
    Posted 9 years ago #

    My password is 13 characters, and it still doesn't work. :(

  4. skeltoac
    Posted 9 years ago #

    This can be a problem with the hostname, too. "localhost" is okay if you have your own server, but many hosting companies provide a separate URL for the MySQL portion of your account. When I had a small GoDaddy account, I had to enter a special hostname. With a larger account, I can use localhost. Check the documentation from your host.

  5. xevious70
    Posted 9 years ago #

    I've been having the same problem regarding"error connecting to database." I'm currently in the process of troubleshooting, including the "localhost" issue. I've noticed separate URL for the MySQL portion of my account...perhaps I'll plug that in and see what happens.

    Regarding the "special hostname" from GoDaddy, did you have to insert the whole hostname in the "DB_HOST" space? What was the format?

    Thanks for your input...

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    With GoDaddy, their hostname is something similar to
    it is never 'localhost'

  7. skeltoac
    Posted 9 years ago #

    When you get a virtual or dedicated server with GoDaddy, localhost works for MySQL. With a regular "hosting" account, you use mysqlXX.secureserver.net where XX is some number.

  8. GrandInquisitor
    Posted 8 years ago #

    I just solved the problem by using - instead of the server name (host name) - the IP address. After struggling with that same annoying error message above, I am now suddenly in! :-)

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.