Support » Plugin: Easy Updates Manager » Conflicts with WP Engine installation

  • UPDATE: I upgraded my review because my host WPENgine found the issue that was causing the plugin not to work properly. Now it works like a charm.

    This conflict may be WP Engine’s fault or the plugins, but it doesn’t work on my WP Engine installation. Numerous attempts to get WPE to fix the problem have failed.

    Would be happy to upgrade this rating if you could help me get the plugin to work.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Contributor Ronald Huereca

    (@ronalfy)

    Sorry to hear that.

    There’s a few WP Engine sites I can test on. I’ll get back to you.

    When you do, take a look at this GitHub thread which details very similar problems specifically with Jetpack Manage which is supposed to permit autoupdating of plugins.

    Mine is the last post in the thread: https://github.com/Automattic/jetpack/issues/2240

    Plugin Contributor Ronald Huereca

    (@ronalfy)

    I tried it on one of my client’s WP Engine sites and the plugins auto-updated as expected.

    Since you’re also having the same issue with Jetpack doing the auto-updates makes things a little more interesting.

    I’ll keep monitoring to see if there is a solution to your issue.

    Plugin Contributor Matthew

    (@kidsguide)

    This could very well just be a plugin or some code in your wp-config.php file that is disallowing you to control updates.

    Does WP Engine play with the update settings in WordPress? I know that GoDaddy and what not are known to turn on or off automatic updates.

    @ Ronald: Can you let me know the domain name of the WPE installation on which the plugin worked. I’m now working with WPE on this problem & they can’t figure out what’s wrong. It would help to be able to look at your client’s installation to diagnose the issue.

    Plugin Contributor Ronald Huereca

    (@ronalfy)

    @richards1052,

    I have let you know via e-mail which domain it is. Please let me know if you did not receive my response as I’d like to keep the domain out of the forums.

    Plugin Contributor Matthew

    (@kidsguide)

    Not to rush you or anything, but were you able to figure out the issue talking to WP Engine?

    @ronald: I never receiced a msg fr you. Could you resend to my gmail acct?

    @matthew: No, WPE never figured it out. But would like to review Ronald’s installation to see how it works there.

    Plugin Contributor Matthew

    (@kidsguide)

    Any luck yet?

    WPE fixed the problem. I got this message from Brando T in tech support:

    I finally was able to get it working on my own install via some nginx rules that I added to proxy_pass the cron job to the correct apache port. Since the plugin is executing a cron job that is then executing a hook that needs read/write capabilities, it needed to go to a different port than what it currently was defaulting to. This was causing our apparmor to block the auto update attempts on the server.

    I am tweaking the rule a bit and should have it fixed up for you shortly. You may see some more emails come through.

    I hope this helps. Your plugin is now working on my site. If you need me to help you reach Brandon, let me know.

    Plugin Contributor Matthew

    (@kidsguide)

    Awesome! Glad they were able to resolve the issue for you.

    Now that it is resolved is it too much to ask that you change your review?

    I was asked to post on this thread instead, although I don’t know that this issue is a conflict with WP Engine (maybe). But I’m working with the same Brandon T from WP Engine support that fixed this issue 5 months ago.

    I’m on WP Engine and have checked the wp-config.php file and autoupdates are not turned off there. I turned on auto-updates in the plugin for themes and plugins. But I left WordPress Core updates off because WP Engine handles Core updates for us and in an automated fashion with a script that checks the update worked successfully and all of that. So I want the plugin to handle plugin and theme updates but not Core updates.

    The updates weren’t working and I worked with WP Engine support and they finally found that if they turned on Core updates in the plugin, the all the plugin updates started working. But if Core updates are turned off in the plugin, nothing updates.

    WP Engine seems to think this is a bug in the plugin as the cron doesn’t seem to be running unless the Core updates option is on. Any insight into this issue?

    I got the above issue working on a particular install and it wasn’t a WP Engine issue for that particular item, however, I tried to use this plugin on a new install and there is a WP Engine configuration change needed to make this plugin work. According to WP Engine support:

    we have to rewrite the port being used by cron jobs to allow it to skip caching, and interact directly with the server

    Once they wrote that NGINX configuration to the install, it began working. Now that I have this rule in place on one of our installs, support said that I can easily have them enable the use of this plugin on future installs by simply using WP Engine support chat and state:

    Copy the NGINX Before rules from the install [install name] to the install [new install name].

    I tried that wording via chat and it worked great!

    Also, I’ve shared the link to this support thread with WP Engine support so they can add anything useful for WP Engine customers that want to use this plugin.

    Plugin Contributor Ronald Huereca

    (@ronalfy)

    Jeremy,

    Thanks. I’m glad WP Engine is willing to work with people rather than add our plugin to the banned list 🙂

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Conflicts with WP Engine installation’ is closed to new replies.