Support » Plugin: External Links - nofollow, noopener & new window » Conflicts with Beaver Builder

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author WebFactory

    (@webfactory)

    Hi, can you please share the URL where we can see the issue or copy/paste the error code.

    Cousett

    (@techiemamma)

    The URL is the internal edit screen with Beaver Builder. I can see what I can find in Console. Happy to add credentials for you to my staging site off the public forum.

    Unchecked runtime.lastError: The message port closed before a response was received.
    pwa-register-sw.js:9 ServiceWorker registration failed: DOMException
    ads:1 Failed to load resource: the server responded with a status of 403 ()
    ads:1 Failed to load resource: the server responded with a status of 403 ()
    fl-builder.min.js?ver=2.2.5.3:6 ************************************************************************
    fl-builder.min.js?ver=2.2.5.3:6 Beaver Builder caught the following JavaScript error. If Beaver Builder is not functioning as expected the cause is most likely this error. Please help us by disabling all plugins and testing Beaver Builder while reactivating each to determine if the issue is related to a third party plugin.
    fl-builder.min.js?ver=2.2.5.3:6 “Uncaught TypeError: Cannot read property ‘5d9f59fbb2deb’ of undefined” on line 9 of https://techiemammastg.wpengine.com/wp-content/plugins/bb-plugin/js/fl-builder.min.js?ver=2.2.5.3.
    fl-builder.min.js?ver=2.2.5.3:6 TypeError: Cannot read property ‘5d9f59fbb2deb’ of undefined
    at Object.onDragHandleHover (fl-builder.min.js?ver=2.2.5.3:9)
    at HTMLDivElement.handle (jquery.js?ver=1.12.4-wp:3)
    at HTMLDivElement.dispatch (jquery.js?ver=1.12.4-wp:3)
    at HTMLDivElement.r.handle (jquery.js?ver=1.12.4-wp:3)
    fl-builder.min.js?ver=2.2.5.3:6 ************************************************************************

    Plugin Author WebFactory

    (@webfactory)

    Hi, we’re looking into this!

    Just to double-check: when you disable our plugin the error is gone? My biggest head-scratcher here is that those errors above don’t reference and of our files + we don’t actually use JS on the front-end.

    Yea it is definitely this plugin. Just happened again now it doesn’t let me get into the builder at all. I can’t find a better plugin for my needs and forgot the name of the one that conflicted so just tried it again. Let me know what I can do to help resolve the error 🙂 I am very good at breaking things. If you want to continue via email or a chat let me know I am on slack in WordPress channels as well.

    Plugin Author WebFactory

    (@webfactory)

    Hi, thank you for letting us know! We’ll dig into this. Are you using Beaver free or pro?

    I am using pro.

    I just wanted to let you know I found this in the same forum. Someone found a fix with a snippet in the functions file

    https://wordpress.org/support/topic/how-to-resolve-conflict-with-beaver-builder/

    I tried it and it worked.

    I seem to still have issues. I added several pages and then just tried one to the exceptions and it still shows up as a nofollow.

    for example, all the links on this page should be dofollow https://techiemamma.com/quick-and-easy-thanksgiving-recipes-for-the-busy-mompreneur/

    The ID is 13655

    I have tried it with several other pages that need the dofollow and to be an exception http://drop.momte.ch/AcfJ5B and with just the one page as the exception http://drop.momte.ch/gLVXLW

    Here is the technical info snippet:
    WP url: https://techiemamma.com
    WP version: 5.2.4
    PHP version: 7.3.10-1+ubuntu18.04.1+deb.sury.org+1
    Active Plugins:
    – AAWP, version: 3.8.14
    – Accelerated Mobile Pages, version: 0.9.98.14
    – Admin Columns, version: 3.4.6
    – AdSense In-feed Placement for WordPress, version: 1.1
    – Advanced Ads, version: 1.14.11
    – Antispam Bee, version: 2.9.1
    – Beaver Builder Plugin (Pro Version), version: 2.2.6
    – Beaver Themer, version: 1.2.4.3
    – Beehive Pro, version: 3.2.0
    – Browser Shots, version: 1.7.4
    – CartFlows, version: 1.3.0
    – ConvertKit, version: 1.8.1
    – Convert Pro, version: 1.4.0
    – Convert Pro – Addon, version: 1.3.0
    – Cookie Notice, version: 1.2.46
    – CustomPress, version: 1.3.7
    – Easy Social Share Buttons for WordPress, version: 6.2.1
    – Featured Image In Rss Feed, version: 2.1
    – FMTC Affiliate Disclosure, version: 2.0.3
    – Forminator Pro, version: 1.10.0
    – Hustle Pro, version: 4.0.3
    – Jetpack by WordPress.com, version: 7.8
    – Official MailerLite Sign Up Forms, version: 1.4.1
    – Post Duplicator, version: 2.20
    – PowerPack for Beaver Builder, version: 2.7.7.2
    – Printful Integration for WooCommerce, version: 2.1.7
    – PublishPress, version: 1.21.1
    – PWA for WP, version: 1.7.1.2
    – Related Posts by Bibblio, version: 1.3.7
    – Schema Pro, version: 1.4.1
    – Show IDs, version: 1.1.3
    – SmartCrawl, version: 2.4.2
    – Smush Pro, version: 3.3.1
    – Stencil for WordPress, version: 1.11.6
    – Tasty Links, version: 0.6.0
    – Tasty Pins, version: 0.8.1
    – Ultimate Addons for Beaver Builder, version: 1.23.1
    – WooCommerce, version: 3.7.1
    – WooCommerce – MailerLite, version: 1.4.5
    – WooCommerce Admin, version: 0.20.1
    – WooCommerce Cart Abandonment Recovery, version: 1.2.0
    – WooCommerce Stripe Gateway, version: 4.3.0
    – WP AutoTerms, version: 2.2.6
    – WP Bitly, version: 2.5.2
    – WP External Links, version: 2.35
    – WPMU DEV Dashboard, version: 4.7.3.5
    – WP Ultimate Recipe, version: 3.12.7

    WPEL Settings:
    array(
    ‘wpel-external-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_blank’,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ‘nofollow’,
    ‘rel_follow_overwrite’ => ”,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘rel_external’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-address-book’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-internal-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_self’,
    ‘target_overwrite’ => ”,
    ‘rel_follow’ => ‘follow’,
    ‘rel_follow_overwrite’ => ‘1’,
    ‘rel_noopener’ => ”,
    ‘rel_noreferrer’ => ”,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ”,
    ‘icon_image’ => ‘1’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-address-book’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-excluded-link-settings’ => array (
    ‘apply_settings’ => ‘1’,
    ‘target’ => ‘_blank’,
    ‘target_overwrite’ => ‘1’,
    ‘rel_follow’ => ‘follow’,
    ‘rel_follow_overwrite’ => ‘1’,
    ‘rel_noopener’ => ‘1’,
    ‘rel_noreferrer’ => ‘1’,
    ‘title’ => ‘{title}’,
    ‘class’ => ”,
    ‘icon_type’ => ‘image’,
    ‘icon_image’ => ‘7’,
    ‘icon_dashicon’ => ‘dashicons-menu’,
    ‘icon_fontawesome’ => ‘fa-address-card-o’,
    ‘icon_position’ => ‘right’,
    ‘no_icon_for_img’ => ‘1’,
    ),
    ‘wpel-exceptions-settings’ => array (
    ‘apply_all’ => ”,
    ‘apply_post_content’ => ‘1’,
    ‘apply_comments’ => ”,
    ‘apply_widgets’ => ”,
    ‘skip_post_ids’ => ‘13155,13157,10187,10222,13655’,
    ‘ignore_classes’ => ”,
    ‘subdomains_as_internal_links’ => ”,
    ‘include_urls’ => ”,
    ‘exclude_urls’ => ‘https://sssteaching.com/
    http://babyoandi.com/’,
    ‘excludes_as_internal_links’ => ”,
    ‘ignore_script_tags’ => ”,
    ‘ignore_mailto_links’ => ‘1’,
    ),
    ‘wpel-admin-settings’ => array (
    ‘own_admin_menu’ => ‘1’,
    ),
    );

    Thank you!!

    • This reply was modified 2 weeks, 5 days ago by Cousett.
    Plugin Author WebFactory

    (@webfactory)

    Thank you for the detailed report!

    We can’t test with all the active plugins you have, but we’re definitely looking into it on a clean install with WPEL and Beaver (free) and we’ll take it from there 👍

    I got Beaver Builder working. The issue is the exceptions not taking effect.

    Plugin Author WebFactory

    (@webfactory)

    Morning!
    Thank you for that detail. We’ll have a closer look at exceptions and find the bug 😉

    Any updates on this? I am having a really hard time getting the exceptions to work or anything to work with this plugin besides just having the nofollow added.

    • This reply was modified 1 week, 2 days ago by Cousett.

    I am trying to ignore certain posts. I am doing the following http://drop.momte.ch/S0Vlzk and then a comma and space for the following http://drop.momte.ch/4ZdmwO am I doing something wrong? The settings don’t seem to apply.

    These are the links that correspond with the post IDs I am trying to ignore. I can do it in code but please provide the exact code I need I did not understand your FAQ.

    Thanksgiving Recipes – https://techiemamma.com/quick-and-easy-thanksgiving-recipes-for-the-busy-mompreneur/- 13655
    Thanksgiving Printables – https://techiemamma.com/turkey-worthy-thanksgiving-printables/ – 13157
    Halloween Recipes – https://techiemamma.com/halloween-recipes-that-will-spook-your-pants-off/ – 13155
    Halloween Tradition – https://techiemamma.com/family-traditions-for-a-spooky-and-fun-halloween/- 10222

    • This reply was modified 1 week, 2 days ago by Cousett. Reason: more info
    Plugin Support Alexandru Tapuleasa

    (@talextech)

    Hi,

    We’re still looking into the issue, hopefully will have a response by tomorrow.
    As for the post IDs to skip you should only separate by a comma without any spaces.

    When I do this it deletes all the IDs except the first one.

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.