WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Conflicting with wp scroll posts

[Resolved] Conflicting with wp scroll posts

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,

    When I am updating Google Language Translator Version 3.0.7 to the current version, I get a fatal error message saying the following:

    “Fatal error: Cannot redeclare register_foo_widget() (previously declared in …/wp-content/plugins/google-language-translator/widget.php:49) in …/wp-content/plugins/wp-scroll-posts/wp-scroll-posts.php on line 386”

    Please check and resolve asap as I am not able to take the benefits of the new version.

    Plugin Author Rob Myrick

    @rm2773

    Hi bikasn, I think the developer of wp-scroll-posts is using the same “sample” widget from the wordpress Codex, for their widget. We need to change the name of either my plugin widget function or theirs.

    OK, so let’s try something – locate this area of widget.php:

    function register_foo_widget() {
        register_widget( 'glt_widget' );
    }
    add_action( 'widgets_init', 'register_foo_widget' );

    Then change it to this:

    function register_glt_widget() {
        register_widget( 'glt_widget' );
    }
    add_action( 'widgets_init', 'register_glt_widget' );

    That might get rid of your error – and sorry for that inconvenience. I’m going to fix that on the next update.

    Rob

    Thanks Rob…

    It worked perfectly.

    Resolved

    Plugin Author Rob Myrick

    @rm2773

    Awesome! I’m glad it worked – thanks for using the plugin

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Conflicting with wp scroll posts’ is closed to new replies.