Support » Plugins and Hacks » [Resolved] Conflicting plugin: WP to Twitter

[Resolved] Conflicting plugin: WP to Twitter

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi Janine,

    Sounds like Javascript conflict. Thanks for the info.

    Plugin Author Marcus


    afaik wp2twitter works fine with EM.

    I fixed a different issue a while back and at the time it worked fine for me.

    It may be that a 3rd plugin or your theme is causing the conflict.

    Hi Marcus,

    I spent quite some time updating my plugins, deactivating them and re-activating again, and the problem only occurs when WP to Twitter is activated. The problem is gone when it is deactivated, even when all the others are activated.
    Also, it only occurs when I am testing as a contibutor (WP role), when I am logged in and testing as an admin, nothing is wrong.


    maybe you check what are those errors using your browser error console to detect javascript error or by turning on wp_debug

    Plugin Author Marcus


    I can test this out and see… just to confirm, is it only a contributor role?

    Thats a pretty odd set of problems to be caused by that plugin. can you confirm where you see this error specifically:

    they keep seeing a blank page, but they can type, but they can only see what they type when they click ‘select all’.

    Thanks Marcus. I am also in touch with the developper of wp to twitter and he now has a contributor role on my website and is checking things out.

    My contributors see a blank field even after typing, when they add a new event and add written info.

    And thanks agelonwl, turned it on and found a few bugs but they don’t seem related to the problem, but maybe one of them is? =>

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or init hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/[..]/wp-includes/functions.php on line 2959

    Notice: Constant USERPHOTO_APPROVED already defined in [..]wp-content/plugins/user-photo/user-photo.php on line 54

    Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in [..]wp-includes/functions.php on line 2925

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in [..]wp-includes/functions.php on line 2839
    (Same with get_theme_data)

    Warning: Cannot modify header information – headers already sent by (output started at [..]wp-includes/functions.php:2959) in [..]wp-includes/pluggable.php on line 876

    Hi again Marcus,

    I got this message from the developper of wp to twitter, and he asked me to ask you for help:

    So, you’re getting an out of memory error. It’s occurring in the
    Events Manager location dropdown; which explains why you’re not seeing
    that dropdown. It’s also preventing the native WordPress scripts that
    run the text editor from finishing loading; which explains why the
    text ends up white — the text editor is incompletely loaded.

    The error is this:

    <b>Fatal error</b>: Allowed memory size of 67108864 bytes exhausted
    (tried to allocate 512 bytes) in
    on line <b>12</b>

    I don’t know why this would only happen for contributors, and not for
    higher-level users.

    Hope you can help!

    I also have no idea why disabling WP to Twitter would have any effect on this; that doesn’t really seem to make sense to me…

    Plugin Author Marcus


    Hey Joe, we meet again 🙂

    Allowed memory size of 67108864

    The only solution here is to up your memory. 64M is low these days, your hosts should help with this and 128M should be enough (unless you’re running 1000s of events, then go higher).

    As for the other errors, I tried this out (as a contributor) and I don’t get any errors. The links work fine, and the issue with your locations is probably because they don’t have the read_others_locations capability enabled, or they don’t have any loations approved to choose from.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Conflicting plugin: WP to Twitter’ is closed to new replies.