Support » Plugin: jQuery Updater » Conflict with YouTube Plugin

  • mywebmaestro

    (@mywebmaestro)



    Please see the video at the bottom of this page: http://mcswma.mwmsite.com – skip to the end of it to see that despite my having the settings checked for not showing related videos, they still show. I posted in the support forum for that plugin, and was given the information below which I wanted to pass on:

    ——————
    It seems like the Jquery Updater plugin is incompatible with wp_localize_script, given the way that plugin deregisters default jquery.

    The WordPress function wp_localize_script is necessary for our plugin (and I’m sure many others out there) to work.

    Right now, the Jquery Updater plugin is just doing this:


    // jQuery
    // Deregister core jQuery
    wp_deregister_script(‘jquery’);
    // Register
    wp_enqueue_script(‘jquery’, plugins_url(‘/js/jquery-3.2.1.min.js’, __FILE__), false, ‘3.2.1’);

    But if it did the following, then it should work (more info here on other people having similar trouble https://stackoverflow.com/questions/29723872/wp-localize-script-not-working-with-jquery-handle/29724589#29724589 ):


    // jQuery
    // Deregister core jQuery
    wp_deregister_script(‘jquery’);
    wp_deregister_script(‘jquery-core’);
    // Register
    wp_enqueue_script(‘jquery-core’, plugins_url(‘/js/jquery-3.2.1.min.js’, __FILE__), false, ‘3.2.1’);
    wp_register_script(‘jquery’, false, array(‘jquery-core’), false, true);

    =============================================================================================
    =============================================================================================

    Post Link: https://wordpress.org/support/topic/related-videos-always-display/#post-9813843

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Conflict with YouTube Plugin’ is closed to new replies.