Support » Plugin: Event post » Conflict with Yoast SEO

  • Resolved wpguillaume

    (@wpguillaume)


    Hello,

    I’m using WordPress 5.2.2 with Classic Editor 1.5, Event Post 5.2.5 and Yoast SEO 11.6.

    In WP dashboard, when clicking the ‘Add Media’ button of the Post Editor, it gets surrounded with blue but the media dialog does not show up.
    Disabling only Yoast SEO or Event Post does not solve the issue.
    Disabling both Yoast SEO and Event Post solves the issue.

    Firefox console shows this:

    TypeError: a.ui is undefined load-scripts.php:11:126
    TypeError: jQuery(…).parents(…).effect is not a function eventpost-admin.js:95:69

    Enabling WP_DEBUG and WP_DEBUG_LOG reports this in debug.log:

    PHP Notice: Undefined index: title in /var/www/vhosts/….fr/httpdocs/wp-content/plugins/event-post/inc/widget.map.php on line 217
    PHP Notice: Undefined variable: key_color in /var/www/vhosts/….fr/httpdocs/wp-content/plugins/event-post/eventpost.php on line 1425

    Thanks for any pointer, I’m stuck!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Bastien Ho

    (@bastho)

    Hi,

    It seems that you have a conflict with the jquery-ui library. Event-Post uses the “native” version from wp-includes.

    Do you use another plugin or theme that brings its own version?

    Hi,

    I don’t know what changed, but the first problem has ‘solved itself’…

    …now I have another one. 🙂
    On the main Dashboard page, I can’t click the Screen Settings button unless I disable either Event Post or Yoast SEO. Also the submenus of the left dashboard menu don’t show up when hovered by the mouse cursor. They do when I’m, say, on the Articles list page, but not on the Dashboard welcome page.
    Firefox console now shows this:

    TypeError: e is undefined load-scripts.php:1:1016

    I’m using a child of the Twenty-Sixteen theme. How do I know if this theme or another plugin ‘brings its own version of the jquery-ui library’?

    Thank you!

    • This reply was modified 3 months, 3 weeks ago by  wpguillaume.

    Following up:
    On a different computer, still with Firefox on Xubuntu 16, only AdBlock Plus installed, the problem’s gone.
    Both Event Post and Yoast are enabled, and I can open the Screen Settings just fine.

    Not sure it has much to do with Event Post, but if you have any pointers, I have no clue where to look next!

    Thank you

    Problem’s gone entirely, can’t tell how it solved itself…

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.