Support » Plugin: Gantry 4 Framework » Conflict with Yoast SEO

  • Resolved sc456a


    Confirmed on multiple sites – when Yoast SEO 5.3+ and Gantry 4.1.13 are both enabled, console errors such as this appear and the Gantry interfaces become unusable:

    wp-seo-babel-polyfill-533.min.js:1 Uncaught TypeError: Can’t call method on undefined
    at b.exports (wp-seo-babel-polyfill-533.min.js:1)
    at b.exports (wp-seo-babel-polyfill-533.min.js:2)
    at Function.from (wp-seo-babel-polyfill-533.min.js:2)
    at fireEvent (mootools.js:374)
    at HTMLDocument.g (mootools.js:514)

    Disabling Yoast solves the issue, but this bug needs to be fixed.

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Gantry


    I just pushed our dev build for internal testing. If the fix will get confirmed – we will release update shortly.


    Plugin Author Gantry


    Ok, so the update has been released. If you update the Gantry 4 to 4.1.14 it should automatically fix the Theme Options page.

    If you update only framework you’ll notice that a bug still exists on the Widgets page, where there is still JS conflict and the dropdown for overrides won’t work.

    HOWEVER I’ve implemented a mechanism to enable/disable YOAST JS on the Widgets page whenever you need it.

    To be able to use it, you need a toggle to enable it to be placed in your theme. We will update all our G4 themes to have it, but until this happens – here are the steps to add it by yourself.

    1. Edit templateDetails.xml in /wp-content/themes/<your-theme>/
    2. Add the code you can find below to the end of the “Gizmos” section of the templateDetails.xml file
      <fields name="yoastwidgets" type="chain" label="Disable YOAST JS" description="Disables YOAST scripts on Widgets page in order to make the page fully working. This affects ONLY Widgets admin page.">
          <field name="enabled" type="toggle" default="0" label="ENABLED" enabler="true" />
          <field name="priority" type="hidden" default="5"/>
    3. Go to Theme Options > Gizmos and locate your new toggle. Enabling the toggle prevents loading of YOAST JS on the Widgets page, so you can control it easily.

    Thanks for your patience.

    • This reply was modified 2 years, 4 months ago by Gantry.
    • This reply was modified 2 years, 4 months ago by Gantry.

    Unfortunately this doesn’t fix the issues with Yoast SEO itself.

    Is there a way to remove mootools from the backend pages where it’s not needed?

    • This reply was modified 2 years, 4 months ago by .


    • This reply was modified 2 years, 4 months ago by newkind.
    Plugin Author Gantry


    Yes, I’m aware of that and that it’s a workaround for the current situation. This was to fix YOAST loading its JS scripts everywhere in admin which btw. isn’t a very good design decision. There’s no point of loading its JS scripts on pages that don’t actually use it.

    To fix this issue completely we would have to rewrite a huge amount of our JS code. This isn’t something that can be handled by changing MooTools version or disabling compatibility layer in it.

    I assume that the issue that’s hurting you most is the Post/Page edit screens where the YOAST controls don’t work right? And you have RokSprocket/RokGallery installed too?

    • This reply was modified 2 years, 4 months ago by Gantry.

    But it looks like you are loading mootools also everywhere in admin 😉

    Yes, it hurts most in the post/page edit screens. Would be a good workaround to make it possible to disable mootools here.

    And yes, I’m using RokSprocket too.

    I’m using the Epsilon theme ( btw. Maybe this information helps too.

    Plugin Author Gantry


    We use MooTools in our theme admin screen, widgets page (overrides dropdown, gantry divider etc.) and post/page edit screens (but only if you use the RokSprocket or RokGallery – shortcode generator). The only compromise I can see right now without rewriting whole JS is to disable the RokSprocket and RokGallery shortcodes generator in the Post/Page edit screens if YOAST gets detected. That way we wouldn’t have to load MooTools in that screen and YOAST should work fine there.

    • This reply was modified 2 years, 4 months ago by Gantry.

    Maybe you could add an option for enabling/disabling the RokSprocket (and also RokBox) Editor Buttons.

    Have you thought about contacting Yoast and asking them to resolve the conflict on their end?

    I contacted them here:

    Also they have a knowledgebase article about that issue:

    Long story short: They would have to rewrite their whole code to make it compatible to MooTools / Gantry.

    But maybe the developers can talk to each other and find a solution.

    • This reply was modified 2 years, 4 months ago by . Reason: typo


    Quick addition – this conflict breaks the very popular Divi Builder plugin as well, making it a bit more serious.

    Any updates on this? @tiiunder, I saw in your Yoast forum post that you see the conflict with RokSprocket, which I’m seeing now as well.

    This really needs to be properly resolved and it’s going to have to be by the Rockettheme team.

    Both sides say the same thing: The others have to fix it. Yes, It’s like kindergarden.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Conflict with Yoast SEO’ is closed to new replies.